Komplete Kontrol SL49 MK2 Stops Functioning Properly in Ableton Live

BMan
BMan Member Posts: 18 Member
edited October 2022 in Komplete Kontrol

Hey all, really could use some advice here.

I recently added a NI Komplete Kontrol S49 MK2 to my setup (complete setup notes at the end), and while I love it, the behavior is a bit weird. What I really like using it for is to browse Komplete Kontrol on the keyboard and change patches, settings, etc. This works great - until it doesn't.

I can't figure out what causes it, but the S49 screens and keyboard light guides will get "stuck" on a specific patch. When I switch through them in Live, while the sound will change, the screens and light guides on the S49 will remain stuck on the same track. For example, I currently have XO on MIDI track 1 and Strummed Acoustic on MIDI track 2. The S49 shows the Strummed Acoustic info (screens and light guides). When I switch to XO on track one, it still displays the info (screens and light guides) for track 2. Also, the wheel stops working (won't switch between tracks or between clips, and the transport controls stop acting like transport controls and just send MIDI note signals.

The odd thing is, this only happens after (1) a certain amount of time or (2) I do something specific (I can't seem to figure out what triggers it). The only way I've found to reliably fix this is to:

  1. In Live -> Preferences -> Link/Tempo/Midi, completely remove the S49 control service from the list
  2. Quit Live
  3. Unplug S49 from the computer
  4. Restart Live
  5. Plug the S49 back into the computer

Now it will function normally - until it happens again. Has anyone else encountered this? I've gone through all the suggestions here and whatever I could find online, but nothing seems to work. I've ensured that in my MIDI preferences, Komplete Kontrol DAW - 1 is selected for both Input and Output for the S49 control surface.

I've followed instructions found at various locations, but nothing seems to help. The odd part is that it functions perfectly fine (and as expected), but then somehow gets "stuck" on a particular MIDI track.

Other things I've tried but haven't eliminated the problem:

  • Starting Live 11 in Rosetta mode
  • Unplugging Push 2 and Mashine
  • AUv2 and VST3 versions of Komplete Kontrol
  • Restarted machine many times

Has anyone else experienced this? Suggestions? Feel like I'm going around in circles trying to troubleshoot. 

Complete Setup Information:

  • Mac M1 Studio running macOS 12.6
  • Ableton Live 11.2 (but also happened in previous 11.x versions)
  • Komplete Kontrol S49 MK2 (firmware version = 0.6.0) [connected via USB]
  • Push 2 controller [connected via USB]
  • Maschine Mikro MK3 [connected via USB]
  • Yamaha CVP-805 [connected via USB]
  • Komplete Kontrol software (version = 2.7.2 R2)

(Disclosure: Also posted this on the Ableton forum)

Best Answers

Answers

  • Paule
    Paule Member Posts: 1,328 Expert

    Do you open a ticket at NI support? The button on top of this page on the right side.

  • BMan
    BMan Member Posts: 18 Member

    Update: I've been communicating with NI support (they've been very responsive). Don't have an answer yet, but we're working through troubleshooting. A few updates though.

    When running Live in native M1 mode and using the AU version of Komplete Kontrol, I can reproduce the issue consistently by:

    1. Save Project, Quit Live
    2. Re-open Live
    3. Re-open the project

    If it does happen in a project, I can also reliably fix it:

    1. Save Live project
    2. In Live Preferences->Link/Tempo/Midi, completely from the S49 from the Control Surface section (set everything to "None")
    3. Quit Live
    4. Disconnect S49 from computer (I unplug the USB B cable from the S49)
    5. Start Live
    6. Open the project you were working on
    7. Re-connect the S49 to the computer

    I've also been messing around with different permutations, and may have stumbled upon something. Previously I had tried using Live in Rosetta mode but I did this again and tested the VST3 plugin again.

    I started a new project, am using LIve in Rosetta 2 compatibility, and am exclusively using the VST3 version of Komplete Kontrol (and other NI plugins), and I'm not able to reproduce the error using the same workflow (quit Live -> Restart -> Re-open project) as before.

    Still working with NI support, but perhaps it's narrowed down to the AUv2 version of the plugin. Maybe this gets fixed when Komplete Kontrol gets updated to Apple Silicon M1 support this quarter?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod
    Answer ✓

    @BMan The Maschine 2.16 and Komplete Kontrol 2.8.0 were released today. Did that have a positive impact for you?

  • BMan
    BMan Member Posts: 18 Member
    Answer ✓

    Awesome, thanks for the heads-up! I haven't had a chance to test yet, but will do so soon and report back.

  • BMan
    BMan Member Posts: 18 Member
    Answer ✓

    Just finished the update to Maschine 2.16 and Komplete Kontrol 2.8.0 (both with native M1 support), and looks like this issue is resolved for me. Thanks!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @BMan That's great to hear, thanks for the update!

Back To Top