M32 as a Midi Controller - trash?

Options
dematre
dematre Member Posts: 4 Member
edited October 2022 in Komplete Kontrol

I'm using Cubase and use the encoders as quick controls.

Problem is if you do anything in Cubase (select a different track etc..) the M32 instantly jumps off Midi Control mode. Then I have to press the SHIFT+MIDI button combination again (which on top of this all has to be done with 2 hands..). This in practice renders the M32 useless as a midi controller.

Is there any way to lock M32 to Midi mode?

Tagged:

Comments

  • JesterMgee
    JesterMgee Member Posts: 2,659 Expert
    Options

    Not that I know of without disabling the control surface function

  • dematre
    dematre Member Posts: 4 Member
    edited October 2022
    Options

    Ye, thought so.

    Really like the encoders on the M32 and loving Komplete Kontrol but it seems really odd that I have to buy additional gizmo just for controlling my DAW's quick controls (I like to use the transport controls on M32 when laying ideas). More wasted space on the desk..

    This works, but is just a nightmare to work with. I'd be ok'ish if you could even press just one button for the midi mode. But 2 buttons simultaneously.. and as far from each other as possible.. sheesh... Must be stupid idea but would it be in anyway possible to get an option to exclude the encoders from the control surface or something?

  • dave251
    dave251 Member Posts: 2 Member
    Options

    Wondering the same thing. Encoders are great but just terrible you have to press shift+midi each time you change track. Shouldn't be a hard thing for the team to change.

  • Kool_aid
    Kool_aid Member Posts: 4 Member
    Options

    NI, please fix this!


    NI support mentioned a workaround for Logic. Can someone please tell me how this would work in Cubase 12?


    "As an alternative, you can try this now. One of my colleagues suggested that you set a key command to "Bypass All Control Surfaces" and use this key command to toggle transport / host integration on and off. In this example I chose letter H (unassigned it from any other parameter) :"


    Thanks!

  • adeser
    adeser Member Posts: 1 Newcomer
    Options

    What seems to work for me in Ableton Live, is to disable all communication from the DAW to the M32. It seems to stay in Plug-In Midi mode even after closing and reopen the app.

  • Tom Macfie
    Tom Macfie Member Posts: 1 Member
    Options

    I've just stumbled across this issue and what worked for me (bear in mind that I don't use Komplete Kontrol) was deleting the M32 from Logic Pro>Control Surfaces>Setup...

    Now the M32 is in MIDI mode even after restarting Logic, with all my CC assignments saved. I suppose if I want to use KK then I'd either have to reinstall the M32 or do what Kool_aid suggested above

Back To Top