S88 on Monterey 12.5, Mac Studio M1 + Pro Tools

mkmig
mkmig Member Posts: 3 Sine

Hi

I've got S88, which I got specifically for using with multiple instances in my template. It worked fine when I was on my old iMac with Catalina. However, when I switched to the new Studio M1 (Monterey) S88 is unusable. It doesn't show instances in my template (Pro Tools), it doesn't let me browse, or view the keys - it just doesn't work. It works as a normal midi keyboard and that's it.

This is a bit pointless because I got it to view the range of the instruments plus quickly use the browsing options.

The answer from NI I got was that S88 is not compatible with M1 yet but would that be the reason for it?

Also - when I use it standalone, it does show the instrument etc. It's just within Pro Tools that it's not behaving properly.

P.S. It was working fine before.

Has anyone had a similar issue or hopefully solutions to that?

Comments

  • Nico_NI
    Nico_NI BerlinAdministrator Posts: 767 admin

    Hey @mkmig, welcome to the online community!

    Have you tried opening Logic with Rosetta? That would be worth trying:

    https://support.native-instruments.com/hc/en-us/articles/4417360007825-How-to-Open-Your-DAW-Using-Rosetta

    Komplete Kontrol M1 compatibility is being worked on and is set to happen fairly soon.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,693 mod
    edited August 9

    @mkmig Even if M1 Max and M1 Pro are not fully supported yet, there are no reports yet of similar malfunctions. I assume our supporters already checked that you had given Full Disk Access to Komplete Kontrol and ProTools. You mention that this only happens within templates, right? It's not happening in a new project, have you tried to create a new template ? Do you think you could send us one of the templates where this issue occurs ?

  • mkmig
    mkmig Member Posts: 3 Sine

    Hi Nico and Jeremy,

    Nico - I use Pro Tools not Logic.

    Jeremy - after the latest updates from Monterey/Pro Tools it seems that S88 is working better. I can switch between the instances and it does show on the keyboard.

    However, the 4-way knob still doesn't work as it should. Rather than switch between Instances it just plays a random MIDI note.

    It does work when I'm in Browsing mode though.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,693 mod

    Oh that's interesting, thanks for the update. Are you using the keyboard as a remote for ProTools? Did you follow the steps in this article ? How to Integrate KOMPLETE KONTROL with Your DAW

    Are you using any other control surface or MIDI device ?

  • mkmig
    mkmig Member Posts: 3 Sine

    Hi Jeremy,

    I've reset my peripherals in Pro Tools and the keyboard now responds well. I can use transport buttons to control PT plus the knob to jump between the instances (and browse). When I select the track the keyboard automatically jumps to the instance which is great.

    The only issue right now is that the Instances window is empty (when I press the Instances button) and can't select from there.

    Other than that, the rest seems to work fine at the minute!

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,693 mod

    At least we made progress! I'll try to find someone to check with a M1 computer, to see if it's a general M1 issue or just a M1 Studio issue.

Back To Top