Problems with DAW functions in Ableton Live with S61 MK2 keyboard

UdoBehm
UdoBehm Member Posts: 28 Sine
edited July 26 in Komplete Kontrol

Good day,

is there anybody experiencing the same issues than I do: If I want to use my KK S61 MK2 keyboard within Ableton Live, sometimes I'm missing the daw functionalities that the keyboard should provide. Means that I can't access the Mixer and I can't transport control Live.

Have talked with the NI support about this several times but they do not got a clue what could be wrong.

Would like my keyboard to work just as normal as it sometimes does in Ableton Live.

Here are my system information (in German language) in case this helps:

Thx for any help!

Udo

Tagged:

Comments

  • JesterMgee
    JesterMgee AustraliaMember Posts: 672 Saw

    You should put your basic system info in your profile or signature to save us having to download and open a text file just to make things a little less annoying and 99% of what is in that file is not needed, just the OS and system specs is all.

    Cannot say I have this issue, things work every time in Live for me but you would need a bit more info gathered on the problem.

    So you say "sometimes" the DAW integration is not working. Is there any pattern to this such as it will not work when you first start Live but will if you do it a second time or you have to switch keyboard off/on to make it work?

    Is it just the DAW integration that stops? If you open an NKS enabled plugin can you (manually) set the keyboard to display the smart controls?

    Can you post a screenshot of your MIDI preferences (as I have a suspicion that is possibly your issue). Specifically what I would like to check is that:

    • Only 1 instance of the KompleteKontrol "Control Surface" script is loaded into one of the slots
    • The Komplete Kontrol DAW port is NOT set for any of the MIDI In/Out options (Track/Remote/Sync)


  • UdoBehm
    UdoBehm Member Posts: 28 Sine
    edited July 21

    Hi Jester,

    thanks for your answer. I've had indeed checked the Track and Sync buttons for the Komplete Kontrol DAW port. Have unchecked them now. Do these two options really cause the DAW functions not to work correctly on the keyboard when they are checked? I think I remember a time when I had them unchecked but the DAW functions didn't work either. Will leave them unchecked now since I do not need them...

    I don't have the Komplete Kontrol S MK2 control surface twice in the list. I'm using another surface that is using the regular Komplete Kontrol MIDI ports of the keyboard however that allows me to control some other functions in Live via the KK MIDI interface. I provide you the script here in case you may tell me whether this could interfere with the DAW functions of the keyboard. However if I disabled the KK2 Macros surface I still sometimes had the same issue of missing DAW functionality of the keyboard in Ableton Live.

    What I currently am thinking of what I could imagine what could be the cause is that Ableton has problems when loading a template that contains one KK (VST3) instance in track 1 - that because of this it doesn't load the DAW functions of the keyboard correctly. The problem always occurs randomly when I open Live. Sometimes it helps when I turn off and on the keyboard again. Sometimes it works after doing it twice. Sometimes I have to restart Live and sometimes even Windows in order I can use the DAW functions of the Mk2 keyboard. What was helping too was re-installing the Bomo MIDI driver that communicates with the keyboard or re-installing the keyboard driver in Windows. However I couldn't make it to solve this problem for all and ever.

    NI was thinking that a driver in the Device Manager could be causing such a miscommunication and advised me to disable or uninstall all audio drivers that I do not need. This didn't solve the issue either however, as far as I've tried the suggestions of the NI support.

    So I hope that disabling the Track and Remote buttons of the DAW port was (all the time) the reason why it did not work and it will work from now on... I doubt however that this will be the case since I think I remember that I disabled these options before and it still didn't work...

    Thanks for your help though!

    Udo

  • JesterMgee
    JesterMgee AustraliaMember Posts: 672 Saw

    Do these two options really cause the DAW functions not to work correctly on the keyboard when they are checked? I think I remember a time when I had them unchecked but the DAW functions didn't work either. Will leave them unchecked now since I do not need them...

    Yes, they can. Because they are DAW control surface ports they are used at a higher level and in my testing, having these enabled for input can (at random) stop things working such as transport/control and auto switching between tracks.

    What I currently am thinking of what I could imagine what could be the cause is that Ableton has problems when loading a template that contains one KK (VST3) instance in track 1 - that because of this it doesn't load the DAW functions of the keyboard correctly. The problem always occurs randomly when I open Live. Sometimes it helps when I turn off and on the keyboard again. Sometimes it works after doing it twice. Sometimes I have to restart Live and sometimes even Windows in order I can use the DAW functions of the Mk2 keyboard.

    Well if you ever have to resort to reinstalling things over and over to get something working, you have more of an issue.

    What you should do is turn the thought into action. Do some controlled tests such as if you think it could be due to using VST3 KK then swap it out and load a VST2 version instead. If you think it could be because of the MIDI options set, take them out and try again for a bit. Also, just tor ule out the fact it isn't the second script you are using for the macro control (I use one too for blue hand control in MIDI mode), deselect that script and test.

    Short answer is it should not be doing what you describe. I strongly suspect it was the MIDI settings you had since I have seen this countless times in peoples issues and replicated the same on my end and it's usually a spot where people get confused because 1 they don't really understand what the ports are actually doing and 2 the manual (tho does not say to select these options at all) does not actually say NOT to select these so people tend to just assume you select these as track/control since you are using them in tracks to control things.... But the signals are not standard MIDI so things get confused.

  • UdoBehm
    UdoBehm Member Posts: 28 Sine

    Thanks for your answer. I've tried disabling the other surface before and start Live without KK being in track 1 (no matter if VST2 or VST3). Nothing helped so far. But I will test again and thank you for this answer. Maybe it helps...

Back To Top