Stop button not working as expected in Ableton Live

DN-01
DN-01 Member Posts: 4 Newcomer

Hello everyone!

I update Ableton Live to 11.1.6 and installed the MIDI Remote Script for Komplete Kontrol S49 MKI (https://support.native-instruments.com/hc/en-us/articles/4406832231441-How-to-Integrate-KOMPLETE-KONTROL-with-Your-DAW).

Before the update, pressing the stop button on the Kontrol keyboard would stop the song and place the playhead at the last selected location. Pressing the button again would place the playhead at the beginning of the song.

Now, pressing the stop button for the first time sends back the playhead to the beginning of the song. This greatly disrupts the workflow because the playhead needs to be repositioned with the mouse every single time. The space bar works fine (start/stop from the last selected location), so I think it may be an issue with the script for the Komplete Kontrol.

Do you have any suggestions on how to fix it?

Thank you very much!

Best Answer

  • DN-01
    DN-01 Member Posts: 4 Newcomer
    Answer ✓

    Hello Everyone!

    I think I was able to identify and solve the issue. I went into Time Machine and looked for the MIDI Scripts I had before and after I installed the new version of Live. The script that works is Komplete_Kontrol_S_Mk1 (Komplete_Kontrol_Mk1 without the _S" does not work as expected).

    In other words, at the time I updated Live from 11.0 to 11.1 a few scripts were deleted from this folder: Ableton Live 11 Suite > Show Package Contents > Contents > App-Resources > MIDI Remote Scripts.

    Please see the attached screenshots of scripts available before (longer list) and after (shorter list) the update to Live 11.1.

    Thank you all for your comments and help!


Answers

  • RedwardMc
    RedwardMc Member Posts: 83 Advisor

    Is there an Ableton option that controls this behaviour?

  • DN-01
    DN-01 Member Posts: 4 Newcomer

    I am not aware of any options in Ableton to fix this. The problem is that Kontakt's transport control is no longer working as it should (it was fine before the update to 11.1.6). The "normal" behavior should be:

    [STOP] Stop playback/recording at current position

    [STOP] Relocate playhead position to song start when stopped


    Any ideas?

  • Uwe303
    Uwe303 Moderator Posts: 2,539 mod

    Then that's maybe something for the native guys to check, @Matt_NI can you help or know where to lead the info to the devs.

  • JesterMgee
    JesterMgee Member Posts: 2,278 Expert

    I think it's something that changed in one of the latest versions of Live, also seems to affect how the encoder wheel works when moving the "playhead" it now no longer triggers playback where you move the marker.

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,437 admin

    I don't think we've done any changes to the script, so might be Live's issue here. Can you reach out to our support team directly so we can verify?

  • DN-01
    DN-01 Member Posts: 4 Newcomer

    Thank you! I submitted a request to the NI support team. I also contacted Ableton support.

  • DN-01
    DN-01 Member Posts: 4 Newcomer
    Answer ✓

    Hello Everyone!

    I think I was able to identify and solve the issue. I went into Time Machine and looked for the MIDI Scripts I had before and after I installed the new version of Live. The script that works is Komplete_Kontrol_S_Mk1 (Komplete_Kontrol_Mk1 without the _S" does not work as expected).

    In other words, at the time I updated Live from 11.0 to 11.1 a few scripts were deleted from this folder: Ableton Live 11 Suite > Show Package Contents > Contents > App-Resources > MIDI Remote Scripts.

    Please see the attached screenshots of scripts available before (longer list) and after (shorter list) the update to Live 11.1.

    Thank you all for your comments and help!


  • Matze0802
    Matze0802 Member Posts: 4 Newcomer

    Hello,

    I have the same issue. Can somebody give mt the correct script for ableton live 11.


    I can not find Komplete_Kontrol_S_Mk1 at NI site.

  • Uwe303
    Uwe303 Moderator Posts: 2,539 mod

    Hello,

    here you will find the scripts or where to find them on your computer depending on the model and so on. Then just copy it into your ableton script folder again and it all should work as before https://support.native-instruments.com/hc/en-us/articles/4406832231441-How-to-Integrate-KOMPLETE-KONTROL-with-Your-DAW

  • Uwe303
    Uwe303 Moderator Posts: 2,539 mod

    Maybe set the permission to the folder folder to only write.

  • Matze0802
    Matze0802 Member Posts: 4 Newcomer

    Thanks ;-)

Back To Top