Low input from vinyl

Brunom Member Posts: 1 Newcomer


The TRAKTOR Z2 shows 'low input' or doesn't seem to find the timecode discs at all. The timecode-discs and the record player (and needle) are perfect.

Sometimes it helps if I give a 'lick' to the tulip cable. But after a couple of minutes, this doesn't work anymore.

It's probably a hardware problem; but did somebody have this before and how did you handle this?

I know it musty have been handled somewhere on this forum before, but I can't find it.




  • djrichy5
    djrichy5 Member Posts: 17 Member

    Have you tried connecting another RCA cable other than the ones used for the left and right decks? I know it sounds stupid to ask, but sometimes RCA cables could be the issue.

    Also, you could use some electronic cleaner to clean the RCA ports. You will need to unplug the power lol. This is what comes to mind initially. Hopefully, these simple fixes solve your issue.

  • Mandiboy
    Mandiboy Member Posts: 8 Member

    Don't know if applicable for Z2, but my A6 sometimes (usually after wake up from hynernarion on WIN) switches input from Phone to Line. Then I have "low input" and I have to manually change the settings in driver configuration.

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin

    Hi @Brunom not sure if you're using Mac or not, but if that's the case have you tried the troubleshooting steps in this article?

    TRAKTOR Does Not Receive Audio or Timecode Signal with macOS 10.14 (Mojave) and Higher

Back To Top