Maschine+ corrupted my SD Card, Neither the M+ nor Mac recognizes it anymore

RichBass
RichBass Member Posts: 27 Member

Has this happened to anyone else?

I was simply downloading expansions on a new SD Card that had been formatted in the Maschine+. It's a Lexar Pro V90 UHSII 300MB/s 128 GB card. There was nothing else on the card... no user content, nothing but Maschine+ installed expansions. Those expansions had been downloaded while the card was in the Maschine+.

My Mac (M1, Monterey) doesn't recognize that there's an SD Card inserted in its slot anymore. The Maschine+ doesn't recognize that it's there either.

I looked for a Lexar data recovery tool and their download link is broken.

Is there a solution, or a way to get the card back?

Tagged:

Comments

  • DeepThumb
    DeepThumb Member Posts: 170 Advisor
    edited June 2022

    Never happened to me. Regrettably IMO nearly no chance. Maybe your SD has just died. Warranty exchange ...

    BTW: I didn't know that M+ is UHSII compatible. My Samsung 256 GB UHSI works well so far.


    EDIT: I might be possible that your MAC has corrupted the 'Linux formatted' SD card. Personally I don't dare to put an externally formatted SD Card into a MAC or WIN PC any more.

  • PK The DJ
    PK The DJ Member Posts: 1,122 Guru

    I had something weird recently after trying to use the SD card in an old USB card reader.

    I assumed that the connections would be made and the PC would see the card, but I guess there's circuitry in the reader that couldn't understand the format of the card.

    When I re-inserted it to my M+ after the reader didn't work, the M+ was unhappy and I thought the experiment had corrupted the card.

    Luckily the old "turn off and back on again" solved the issue, but it was certainly a heart-in-the-mouth moment.

  • RichBass
    RichBass Member Posts: 27 Member
    edited June 2022

    @DeepThumb I saw somewhere on a this forum that it was claimed UHSII would work. I think the individual was even associated with NI. In any case, on a second reading of my message, I can see how I wasn’t clear. The card suddenly died while in the Maschine+, having never set foot in another device up to that point. I only tried reading it on the Mac after it had gone unrecognizable, thinking that the M+ was having trouble recognizing. I was testing “is it truly corrupt, or does the maschine just think it’s corrupt?”. I later tried it in my camera to confirm and while the camera indicated that it was trying to read the card (I suspect my camera has an insertion sensor), it ultimately was not able to read the card.

    @PK The DJ thanks for sharing, gives a good reason to only use a one card, one device discipline! I get enough panicky moments with technology as it is!

    I think I’m going to try using a USB drive instead. Luckily I had no work/projects on the card, but unluckily I have yet to produce any work as a result of tech issues. This is perhaps lucky for any potential listeners of my work lol

  • ozon
    ozon Member Posts: 1,353 Expert
    edited June 2022

    Was the card new or used before?

    According to this blog post, the minimum requirements are as follows:

    MASCHINE+ ships with a 64 GB SD storage card, but you can use a standard SD card up to 1TB in its place for additional space. A fast card – like the SanDisk Extreme, for example – comes recommended.


    If you want to be more precise, the included card has the following specs. You’ll want any replacement to meet or exceed these: UHS-I, U3, Native I. Class 10, V30. A1.

    As far as I remember posts on the (old) forum about SD card problems, it was often related to the no-name SD card shipped with the M+.

    Since you have problems with an expensive high performance card, it could also be that the SD card reader went bad.

    Did you try reformatting the card?

  • D-One
    D-One Moderator Posts: 2,882 mod
    edited June 2022

    AFAIK UHSII is retro compatible, kind of like USB2 and USB3; the extra pins just aren't used and it runs slower than it's full speed, it shouldn't cause any issues.

    Keep in mind an SD Card failing is not exactly a rare thing, probably due to the nature of exFAT, it's the reason Sandisk offers a Recovery tool voucher for free when you buy an SD, even expensive brands fail sometimes.

    Here's the link for the lexar tool:

    https://www.lexar.com/en/download_cat/recovery_tool/

  • RichBass
    RichBass Member Posts: 27 Member
    edited June 2022

    It was neither an old card nor a new card, but was used at one point before it saw Maschine. It sounds like it’s toast and not Maschine’s doing. I ordered a new card so hopefully that one works better (or longer). Thanks @D-One for the link, I couldn’t seem to find that perusing their site. (Edit: it’s not that I couldn’t find it, but rather that the download isn’t giving me a file that seems like a recovery tool… I’ll need to reach out to Lexar support)

    I am displeased to have to use this medium for storage. Oh well.

Back To Top