Controller Editor Fails to Download on MacOs Catalina (10.15)

13»

Answers

  • Miguel Ramon
    Miguel Ramon Member Posts: 4 Newcomer

    Hello Jeremy and thanks for your help.

    It's not working for me yet...I have an empty Controller Editor folder after install from the downloadable dmg you posted...

    More details: I'm having the same issue on Mac OS Catalina 10.15.7 2,5 GHz Dual-Core Intel Core i5

    None of my hardware instances or the Controller Editor seem to work. No LOGIC or Ableton Live Suite 11


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,637 mod

    @Miguel Ramon I just tried to download and install from this dmg and it worked. Can you try deleting the Controller Editor folder and then install from the dmg file ?

    After some tests I also found out that installing or reinstalling Komplete Kontrol or Maschine from Native Access will install the correct version of Controller Editor.

  • Miguel Ramon
    Miguel Ramon Member Posts: 4 Newcomer

    @Jeremy_NI thanks for your help.

    I've tried deleting the CE folder, re-installing Maschine and Komplete Kontrol and nothing!

    Anyway the A49 and the Mikro MK3 at least are alive now...on the standalone mode :o


  • phillippitts
    phillippitts Member Posts: 1 Newcomer

    I am have the same challenge as well (Mac 2.9 GHz 6-Core Intel Core i9, Catalina). I have also attempted the process/download install mentioned above and have been unsuccessful at said repair.

  • Richi (SDC)
    Richi (SDC) Member Posts: 22 Member

    disappear again...


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,637 mod

    @Miguel Ramon @phillippitts @Richi (SDC) I've contacted you by email, we need more info on your system.

    For other affected users on Catalina where Controller Editor doesn't show up in the Application folder, even after installing from Native Access or from the dmg file, please get in touch here: http://bit.ly/NIsupport_install

    Please specify "Controller Editor missing on Catalina" inyour request and include the result of the support tool.

  • Miguel Ramon
    Miguel Ramon Member Posts: 4 Newcomer

    Hi again @Jeremy_NI and thanks for your help.

    I've replied and sent you what you requested via email.

    👍️

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,637 mod
    edited August 2022 Answer ✓

    Little update: It seems some Catalina users have issues with installing Controller Editor 2.7.3. Here you can find an installer for the previous version: Controller Editor 2.7.1

    If you are a Traktor user and have a S4 Traktor controller, you should use an even older version: Controller Editor 2.6.2

  • s4mk3
    s4mk3 Member Posts: 33 Helper

    I still haven't figured out how to fix controller editor in Native access? Has zero issues using traktor but every time I open native access it's showing repair. controller editor version 0.0.0

    mac 10.15.7 Catalina

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,637 mod

    @s4mk3 Well, if you use the S4 mk3, please note that the newer versions of Controller Editor are not working well with the controller. Traktor Pro 3 installs the right one for you which is version 2.6.2. CE is also used for other software/hardware integration like Maschine or Komplete Kontrol, this is why it's showing as repair. In your case you shouldn't do anything. Hopefully this is fixed soon.

  • krissi b
    krissi b Member Posts: 2 Newcomer

    2.7.1 worked for me straight away. Every other version doesn't. Thanks!

Back To Top