Controller Editor Fails to Download on MacOs Catalina (10.15)

Chensa
Chensa Member Posts: 3 Sine
edited August 4 in Native Access

When I opened Native Access, I noticed the Controller Editor failed. After attempting to download it again and then having it fail again, I decided to uninstall it using the "how to" video provided on the NI website. (LOTS of files).

Restarted my computer.

Opened Native Access and began reinstalling again. And yet, "Installing Controller Editor failed: An error occurred while running the installer."

So now what do I do??

MacOS Catalina 10.15.7

Best Answer

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,797 mod
    edited August 4 Answer ✓

    Little update: It seems some Catalina users have issues with installing Controller Editor 2.7.3. Here you can find an installer for the previous version: Controller Editor 2.7.1

    If you are a Traktor user and have a S4 Traktor controller, you should use an even older version: Controller Editor 2.6.2

«13

Answers

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,406 admin

    Hi @Chensa can you make sure that Native Access has "Full Disk Access" just in case? You can find the settings in Mac's system preferences.

  • DS99
    DS99 Hannover, GermanyMember Posts: 14 Sine
    edited June 21

    Same issue here. Even repair via Native Access doesn´t work. After looking into NI applications folder, I found out that the Controller Editor App is completely missing. As the app has been removed, repair is not possible. On my desktop (old alias of app) the app was replaced by a file "NI Controller Editor.ncc". Please see attached screenshots. I´m on Mac Catalina 10.15.7.


  • bokstudio
    bokstudio Member Posts: 1 Noise

    Hi, same problem here!

    The Controller Editor is missing from the NI folder, can't repair, nothing happened. I have tried to reinstall it again from native access and downloading .dmg file from support forum, everything seems to be fine, installation complete but it does not install anywhere visible.

    I have this files on Library/Preference in case it helps:

    com.native-instruments.Controller Editor.plist

    com.native-instruments.Controller Settings.plist

    com.native-instruments.Controller Settings.plist.BuwaeTr

    com.native-instruments.Controller Settings.plist.K6TpFlR

    com.native-instruments.Controller Settings.plist.VagkSH4

    Thanks in advance.


  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,406 admin

    @Chensa @bokstudio @DS99 Do any of you have registry cleaning apps like Clean My Mac installed? If so, pls uninstall them since they can mess with the files...

    I think it might be better if you get an installer directly from our support team, so I've created support tickets for you instead. You'll hear back from us soon.

  • ElectricNomad
    ElectricNomad Member Posts: 3 Sine

    I am having the exact same problem. Reinstalled using the .dmg file. I have completely reinstalled all of my Native Instrument files (Traktor). Uninstalled everything Native Instruments and then reinstalled everything. Still no Controller Editor. Cannot find the application in the Controller Editor folder or anywhere! Please help! I have followed every help document I can find. I have given Native Access full disk access. I´m on Mac Catalina 10.15.7.

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,406 admin

    Hi @ElectricNomad I see that you already got a download link for the latest version of Controller Editor from our support team as well. 👍

  • ElectricNomad
    ElectricNomad Member Posts: 3 Sine

    Hi Kaiwan_NI, yes, the latest version of Controller Editor from the support team has resolved the issue. Thanks for responding.

  • Sfality
    Sfality Member Posts: 1 Noise

    Hi Kaiwan_NI, I have the same problem, which version are you referring to? thanks.

  • Rhoney G
    Rhoney G Member Posts: 1 Noise

    Hello Kaiwan_NI, What do I have to do to fix this problem on my system also??? I've tried to download the latest version(2.6.2) on the site, but no dice. pls help me resolve this soon. Thanks.

  • HectorDelgado
    HectorDelgado Member Posts: 3 Noise

    same issue here


    Catalina 10.15.7

  • dcruz
    dcruz Member Posts: 1 Noise

    @Kaiwan_NI Also having the same issue, can I get a download as well? Catalina 10.15.7

  • Richi (SDC)
    Richi (SDC) SDCMember Posts: 4 Sine

    same issue here and the operating system freshly installed



  • s4mk3
    s4mk3 Member Posts: 9 Sine

    Same issue Catalina 10.15.7

  • ness
    ness Member Posts: 2 Noise

    Same here - Catalina 10.15.7 the dl-link is not available for public?

  • Jovani Silveira
    Jovani Silveira Member Posts: 1 Noise
    same problem. the installation completes but the "controller edit" folder is empty. I don't have access to the app. Help me, please
    


Back To Top