Enter key doesn't work in Komplete Kontrol browser?

RandomS
RandomS Member Posts: 3 Noise

I'm using Komplete Kontrol 2.7.0. When I run the standalone Komplete Kontrol software, I can use the up- and down-arrow keys to browse through presets, then hit Enter to load a preset. When I run KK as a plugin in my DAW, the arrow keys let me browse through the presets the same way, but the Enter key does nothing. (I've tried it in Ableton Live and Bitwig Studio.) The only way to load a preset is to double-click it with the mouse - annoying. This must be a bug, right? Why doesn't the plugin version of KK have the same keyboard shortcuts as the standalone version?

Answers

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 824 Saw

    not a bug, the host DAW Steals the Enter key...some DAWS have options to pass all key presses to plugins, not sure about Ableton or Bitwig.

  • RandomS
    RandomS Member Posts: 3 Noise
    edited May 7

    It doesn't look like the DAW is stealing the Enter key. In Kontakt's Quick Load pane, the Enter key works fine to load an instrument. The only plugin I've found where the Enter key doesn't work is Komplete Kontrol.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 638 mod

    Hey @RandomS It is a limitation of Plug-ins. By default the DAW intercepts the key commands. You will see similar behaviour in Plug-ins from other manufacturers too.

  • Syngularity
    Syngularity Member Posts: 3 Sine
    edited May 10

    It's particularly annoying, when you are familar to browse presets within U-He plugins or Omnisphere with the arrow keys, for instance. And then alternatively open them within the Komplete Kontrol plugin - for using its benefits -, you will have to mouse click orgy again.

    Developers should do everything possible to avoid mouse click orgys today!

  • RandomS
    RandomS Member Posts: 3 Noise


    There must be a disconnect here. As I already said, the Enter key works fine in Kontakt and every other plug-in I've tried (from NI and other manufacturers). In fact, the Enter key even works in the Files tab of Komplete Kontrol's Browser! The only place where the Enter key is not working for me is in the Library tab of Komplete Kontrol's Browser. There is just no way that this behavior can be a limitation of plug-ins - it must be a problem with the Komplete Kontrol software.

Back To Top