Kontakt 6 loading in Komplete Kontrol (instead of 7)

aka
aka Member Posts: 46 Member
edited March 11 in Kontakt

Money into a drain :-( I paid $600 for the recent Komplete Kontrol upgrade. Not only I have lost presets for each Komplete Kontrol track (with the message "KK vst2 plugin not found") on over 30 projects (each having from 3 to 12 KK tracks).

Now loading KONTAKT7 into Komplete Kontrol and launching one of the standard NI presets I get the Error message. Of course I know why this happens, because when I check Kontakt version loaded into KK it shows v6. I then reload Kontakt7 into KK, open the preset and everything is fine until I decided to reload another presewt or simply start playing with different LIBS, Suddenly (while keeping the KK window open I get this same Error, and when I check the Kontakt version it is v6 again. What is going on here ?

Can somebody from NI could asnwer in public why such a ****** is even released to the public for money ?

It ialmost impossible to work like that. Anybody has a solution for that ?


======================

running: Win10/Pro, Ableton11+/Studio One6+, Kontakt

Answers

  • mykejb
    mykejb Moderator Posts: 1,155 mod

    Do you have "Always use latest version of NI software" ticked in the preferences for Komplete Kontrol? It's at the bottom of the Plugins page. That should fix the Kontakt version problem.

    Komplete Kontrol doesn't support VST2 from version 3 onwards. Do you have one of the new MK3 keyboards? If you don't the easiest solution is to roll back to KK 2.9.6 which you can get from here - Komplete Kontrol Legacy Installers for Older Operating Systems – Native Instruments (native-instruments.com)

    If you do have a MK3 keyboard then the only option I know with Ableton at least is to replace the KK2 VST plugin in the tracks with the VST3 version. I think some people had success saving a copy of the VST2 dll, installing the new version then copying the VST2 version back. Check this thread for details - How to fix Komplete Kontrol VST2 after 3.0 update ? — Community (native-instruments.com)

  • aka
    aka Member Posts: 46 Member
    edited March 11

    Thank you for replying.

    I think I got the first issue (loading Kontakt6) fixed, but this was minor. The major one is still valid and basically I cannot work now on any existing project. Completely stuck and angry.

    I have everything revert back to KK v2.8+ but when I opened the Apbleton project I still got the same Error (plugin not found). I 've seen these threads but none of them helped me. For the last month, no matter what I do I cannot get the KK v2 restore their presets and all together there would be ove 200 tracks...in multiple projects. Total disaster.

    On top of that I am working on some new projects using KK v3 so I cannot completely discard v3. It's being a total mess and I am really sorry I've made the mistake upgrading and creating this mess for my own money :-(

    I use NK keyboard but it is Mk-1. Seeing all the issues I am not planning to buy any other keyboards (and possibly software) from NI. Now my only goal is to restore months of work... and NATIVE INSTRUMENTS is not help full in fixing the mess they created.

    I have checked the link you posted few days ago and they claim the latest KK v3 should recognize the vst2 presets or whatever. This post and information so very unclear and confusing. I got to the poin I was able to see KK v4 on my plugin list, but when I opened the project the tracks with KK v2 were still missing presets.

    So far I so no solution. Perhaps I would have to restore my entire OS to the previous version from 2-3 months to get this to work, but then I would loos lots of present stuff :-(

  • PoorFellow
    PoorFellow Moderator Posts: 2,472 mod
    edited March 11

    If you mess around a lot doing both this and that then you might end up where it will be hard for anyone to understand what is happening.

    But are you not supposed to somehow 'reset' the Ableton plugin database or something ? if you change plugins ? Or is that going to screw things up even more ? Also , there are both reset you can do of both Komplete Kontrol app and the Kontakt app but with a type of problem like this then I have no idea if it will just make matters worse ! As far as I have understood then you are supposed to revert to the version 2.9.6 of KK as Mykejb suggests above and I thought that it were then kind of going to fix itself .

    I think that we ought to ask @Jeremy_NI if he knows enough about Abletion to have any good advice here ?

    [OP also made a post over today] and [OP also made this thread today !]

    (quote OP : I have everything revert back to KK v2.8+ but when I opened the Apbleton project I still got the same Error (plugin not found).)

  • aka
    aka Member Posts: 46 Member

    Well, that is what I did. I reinstalled KK vst2, but then I started having all kind of other problems on top of the fact that I kept getting the same Error (in KK tracks) in Ableton. I just started working with Studio One so have no projects for KK vst2, and this has not been affected.

    I would really demant from NI to create some forum section and special page with comments available to keep this huge issue resolved and give users advice based on their DAW and OS. Their general posts and suggestions work for some but not for many (I am one of them). Now I have tons of work to finish and I can't!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,547 mod

    @aka First of all, it would be recommended to install the 2.9.6 version of Komplete Kontrol.

    Here it is: Komplete Kontrol 2.9.6 (Windows) Double check that the vst2 file is present in Ableton's plugin preferences folders, see Plug-In Administration in Ableton Live and

    What I would recommend is to take care of this issue for Ableton first, and for the time you'll be doing that, remove the vst3 file from it's folder, even the Komplete Kontrol 3.xx from your programs. You can uninstall version 3xx for now and reinstall it afterwards. I imagine that getting these projects back is the priority.

    Ableton doesn't allow vst2 to vst3 migrartion so at some point you will need to migrate those yourself.

    It's a quite difficult issue, there's not really a simple and unique way to fix it, it depends a lot on different setups, so don't hesitate to contact our support about it, they can help. I see that you mention support requests on the other thread and I've answered that.

    It's also not necessary to create different threads for the same issue, it only makes things harder for us to help you out.

Back To Top