S88 MK2 Transport Keys Seize Working With Komplete Kontrol (Ableton 11)

UlfTheWolf
UlfTheWolf Member Posts: 6 Sine
edited April 23 in Komplete Kontrol

Hey there,

I'm running into a peculiar issue in Ableton 11 (Trial) where the transport key functionality drops out when a session containing a Komplete Kontrol VST is opened.

In a blank session the transport keys work. Mixer and mute/solo keys are lit and all the keys and encoders work properly. When I then add Komplete Kontrol to a Midi track it still works just fine, until I save and restart that session. Mixer mute and solo keys then just go dark and it won't let me return to the mixer section or use any of the transport keys.

On a sidenote I also started out using the wrong manual to install the host integration files since there seem to be multiple versions. I arrived at the conclusion that the host integration steps aren't necessary anymore since Ableton 11 provides the Komplete Kontrol S Mk2 Control Surface Midi script.

So my exact steps were these:

•Install Komplete 13 via Native Access (I use custom VST32 and VST64 folders to keep them grouped and out of my system folders)

•Open Komplete Kontrol and let it scan the available instruments

•Set up the Audio and Midi section for Komplete Kontrol standalone

•Set up Komplete Kontrol standalone with the custom paths, then rescan

•Trying out some instruments in the standalone to make sure Midi works

•Closing Komplete Kontrol

•Keep reading the old manual that refers to older versions than Ableton 10.1

•Follow the Host Integration steps and drag the folder _Nativeinstruments and Komplete_Kontrol_MK2 into Ableton's Midi Remote Script Folder

•Then also follow the instrument rack instructions and drag the .adg into the user folder etc.

•Turns out the Komplete_Kontrol_MK2 Control Surface does not show up, only Komplete Kontrol S MK2 and the A series Control Surface option

•Trying it with the Komplete Kontrol S MK2 Control Surface worked partially at that point the DAW controls were overriding the Komplete Kontrol plugin, whenever I switched to Mixer and used the Encoder to navigate I could not return to the Komplete Kontrol Plugin until I used my mouse to click on the little Piano symbol inside the VST (I assume to switch instances)

•I tried removing the newer Midi Scripts from the folder and using the old Komplete Kontrol MK2 script which didn't end up working. That seemed to have broken Ableton somewhat so I reset it by deleting preferences and the templates folder.

•After the fresh start I just used the new Komplete Kontrol S Mk2 script and after that the behavior changed to what I described initially.


My current working theory after this writeup is, that me following the host integration instructions from the old manual and dragging the _Nativeinstruments folder into Abletons Midi Scripts folder screwed things up as this likely wasn't reset by deleting preferences and templates in Ableton. I'll update once I reinstalled Ableton completely.

Edit: Reinstalled the Ableton Live Trial, made sure to delete the Appdata Local and Roaming folders too, the issue persists just as described.

Edit2: Maybe something to note is, that instead of controlling transport within the DAW once the control surface functionality drops out it sends midi notes instead playing instruments that I select in Komplete Kontrol.

Edit3: I don't know why I hadn't tried it earlier but I used Maschine now instead of Komplete Kontrol and Transport works just fine with it. Even after restarting the session I keep the controls. However I still have to open the VST first and click on the piano symbol to gain access to the Plug-In and Browser. I was sure that once I select a track with a Native Instruments VST the S88 should take control over it by itself.

Tagged:

Best Answer

  • UlfTheWolf
    UlfTheWolf Member Posts: 6 Sine
    Answer ✓

    Alright I fixed it. In a Reddit post I saw it being mentioned that Komplete_Kontrol_VST.adg is calling the VST2 and not the VST3. Native Access installed all the plugins into my VST3 folder including the .dll files. Moving the Komplete Kontrol dll file to the VST2 folder allows the instrument rack to load it and now it properly switches between MIDI and Plug-in mode. Transport control is also permanent now and mixer works too.

    So there you go, if you leave everything installing in default folders you save yourself a headache. I just couldn't do it due to space restrictions of my OS install SSD and the custom VST folders made it a bit harder to figure out.

Answers

  • Uwe303
    Uwe303 Moderator Posts: 359 mod

    This should not happen, cause transport and such stuff is handled by the DAW midi port, and midi to a instrument instance is via the other midi port. And the transport buttons have to work all the time for sure, are you sure that your settings are correct, I mean the yellow buttons right from the port settings, so please make a picture of your midi settings.

    Uwe

  • JesterMgee
    JesterMgee Custom NKS Libraries: freelancesoundlabs.com/nksMember Posts: 391 Saw

    Edit2: Maybe something to note is, that instead of controlling transport within the DAW once the control surface functionality drops out it sends midi notes instead playing instruments that I select in Komplete Kontrol.

    That is suggesting to me that possibly in your MIDI preferences you have the Komplete Kontrol MK2-DAW port selected as a MIDI input. Make sure it is NOT selected as an input or output in the MIDI settings as this will cause issues.

    It won't matter either if you copied the old driver for the MK1 keyboard also, they are different and even if you selected it there would just be nothing happening. As you have discovered, the driver for the MK2 keyboard is installed with Ableton automatically now.

  • UlfTheWolf
    UlfTheWolf Member Posts: 6 Sine

    Hey, thanks for your answers, currently it's looking like this. The Komplete Kontrol DAW - 1 is indeed set as a MIDI Input device. I personally know nothing about the yellow checkboxes below. None of the Out boxes are ticked if I scroll down.

    Anytime I set the Input and Output on the Control Surface to None it defaults back to Komplete Kontrol DAW - 1 immediately after restart.

    I get some weird behaviors with the keyboard. I closed the session with mixer selected, then restarted the session with a track containing Komplete Kontrol and now the Plugin and Browser buttons are lit but the Mixer light went out, (once loaded into the session it defaulted to the Plug-In view on the small monitors) if I press the mixer button it won't switch into the usual mixer view, only the white top buttons change but the Plug-In view remains with all white keys lit up.

  • JesterMgee
    JesterMgee Custom NKS Libraries: freelancesoundlabs.com/nksMember Posts: 391 Saw

    I personally know nothing about the yellow checkboxes below.

    Worth learning about since it can save you headaches like this when you understand the differences between MIDI In/Out and Control ports.

    This should NOT be selected and is probably your problem right here:

  • UlfTheWolf
    UlfTheWolf Member Posts: 6 Sine
    edited April 26

    I tried disabling the pointed out track checkmark and as a result it at least doesn't play notes anymore. However the transport keys now just don't do anything at all. Mute and Solo lights are also still off, so is the mixer. So basically still the same behavior.

    Even before writing my initial post I contacted NI support and today they replied with the suggestion to install Controller Editor 2.7.1 and to then restart the PC. Checking the version of my current Controller Editor it turns out that I was on version 2.6 so it looked promising until I restarted the PC and we're still at exactly the same point.

    I'm starting to consider that it might be the Ableton Trial version? Sounds a bit dumb but I'm at a loss what it could be. The way Ableton made it easy with their own Midi Remote script does imply that it should be plug and play but maybe I'm naive about that.

    Edit: Let me know if there is any point to the Controller Editor idea as I'm sure you're replying much quicker than the support will. It doesn't look like a program that helps me much in this situation.

  • Uwe303
    Uwe303 Moderator Posts: 359 mod

    It should work with every ableton version, do you had the keyboard unplugged while installing ce? Even if o don't think that makes a difference in this situation but maybe worth a try, so uninstall CE and install with the keyboard off or unplugged.

    Uwe

  • UlfTheWolf
    UlfTheWolf Member Posts: 6 Sine

    Alright, I removed CE via add/remove programs unplugged the S88 and reinstalled the 2.7 version provided by the NI support. Then I restarted, launched CE once and tried to open a session containing a Komplete Kontrol VST. Same thing as usual, plugin and browse work, no light on Mixer, Mute or Solo and no working transport keys.

  • Uwe303
    Uwe303 Moderator Posts: 359 mod

    Ohh and after installing anything you should start komplete kontrol stand alone once first, then open ableton. And if you are in ableton and press mixer nothing happens? Or load two instances of the provided adg file and use instance or select a track containing the adg file via mouse should also switch the keyboard to that instance. Could it be the case, that you accidentally have learned a midi function somehow and this causes the issue?

    Uwe

  • UlfTheWolf
    UlfTheWolf Member Posts: 6 Sine

    I made sure to run Komplete Kontrol Standalone this time. If I open a clean live set without any instance of Komplete Kontrol in it, then transport works just fine and keeps working until the set is reloaded. However now that you mention the .adg, I have trouble with that. The Komplete_Kontrol_VST.adg only opens an empty instrument rack for me. It is supposed to call up the actual VST without me adding the VST3 from my Plug-In list, right?

  • UlfTheWolf
    UlfTheWolf Member Posts: 6 Sine
    Answer ✓

    Alright I fixed it. In a Reddit post I saw it being mentioned that Komplete_Kontrol_VST.adg is calling the VST2 and not the VST3. Native Access installed all the plugins into my VST3 folder including the .dll files. Moving the Komplete Kontrol dll file to the VST2 folder allows the instrument rack to load it and now it properly switches between MIDI and Plug-in mode. Transport control is also permanent now and mixer works too.

    So there you go, if you leave everything installing in default folders you save yourself a headache. I just couldn't do it due to space restrictions of my OS install SSD and the custom VST folders made it a bit harder to figure out.

  • Uwe303
    Uwe303 Moderator Posts: 359 mod

    correct, i also found that out by trying myself 5 min ago, you need to use the vst2 plugin, but you fund out yourself.

    Uwe

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 674 mod

    @UlfTheWolf Since Ableton 10.1 and Komplete Kontrol 2.1.2 you don't need adg files or remote scripts for Ableton's host integration. How to Integrate KOMPLETE KONTROL with Your DAW

Back To Top