Where did the auto/default grid marker go?

It used to be that loading any new track would automatically place a grid marker around the start, but from a few releases back it seems to have permanently disappeared. While it was often not in quite the right place, it was better than nothing in a quick-and-dirty moment. Is there any way to re-enable this? I've looked through preferences etc but can't see anything that leaps out. Any ideas as right now until I drop a grid marker it's just a forest of lines.

Cheers

«1

Comments

  • muthafunka
    muthafunka Member Posts: 22 Helper

    No-one? Any preference I can enable to get this back?

  • lord-carlos
    lord-carlos Member Posts: 2,053 Expert

    I think I only have this when when the song is not analyzed before loading.

  • ErikMinekus
    ErikMinekus Member Posts: 13 Member

    What do you have set under Preferences > Analyze Options?

  • muthafunka
    muthafunka Member Posts: 22 Helper


    Hi, I have 'Set Beat-Grid when detecting BPM' checked.

    When I analyze I use 'All' but even using Special and making sure BPM and 'Set Beatgrid' are checked, I get the same result which is a load of grid lines at various drum hits. Previously there would be a grid marker auto-set and a regular grid ....even if it was a few ticks off it was still often better than nothing.

  • mykejb
    mykejb Moderator Posts: 867 mod

    Just to check, which version of Traktor are you using? Are you on 3.11.1 ?

  • muthafunka
    muthafunka Member Posts: 22 Helper

    Hi, yes, whatever the latest version is via Native Access as of yesterday.

  • lord-carlos
    lord-carlos Member Posts: 2,053 Expert

    And grid is not locked?

  • mykejb
    mykejb Moderator Posts: 867 mod
    edited February 19

    I just tried this with a random track (Another one bites the dust - Queen). When I analysed it, it put a single cue point on the first downbeat which is what I'd expect. I tried a different track and loaded it without analysing first, and the same happened. I had a single cue point pretty much on the first downbeat.

    Both "Set beat grid when detecting BPM" and "Store beat marker as Hotcue" are enabled in the Analyze Options. Without "Set beat grid" set, I just get the vertical lines as you described. Can you check your settings in case they got changed at some point?

  • muthafunka
    muthafunka Member Posts: 22 Helper
    edited February 19

    Thanks for your time. Yes, both are checked - I even tried unchecking/closing/reopening/re-checking and still the same loading both un-analyzed and analyzed tracks.

    One thing I JUST noticed, which I assume is connected, is that I can't write ANY cue markers, not from my keyboard or even the cue buttons in Traktor...what the heck???

  • mykejb
    mykejb Moderator Posts: 867 mod

    Are your files read-only, or are they located on a read-only volume on your Mac like an NTFS volume on an external disk?

  • muthafunka
    muthafunka Member Posts: 22 Helper

    They're all read/write to everyone and on the internal drive. Same with the Traktor folder in Documents...but that does seem to be connected for sure. I can click to add cues and the button flashes but then just disappears again instantly.

  • mykejb
    mykejb Moderator Posts: 867 mod

    Maybe your collection file is corrupt? You could try backing it up and creating a new collection, add a single track to it and see if that works.

    In Options/File Management do you have "Tag writing mode" set to "write all tags"? You could try setting it to "Do not write any tags" and see if that helps.

  • muthafunka
    muthafunka Member Posts: 22 Helper

    I tried all of those and no success.

    As I said all files appear to be write-enabled, I did the 'apply to all enclosed files' in permissions as well as checking rhythm individually, and they should all be writable by anyone. If I was able to add cues etc, where is that info written, in the individual music file itself or somewhere in the Traktor folder?

  • mykejb
    mykejb Moderator Posts: 867 mod

    It's written into the music file if you have tag writing mode set to "write all tags" or "write traktor tags". It's always written into the collection.nml file.

    You could try renaming the Traktor user folder in Documents to another name then run Traktor. It should then go through the initialization again and resets all the default options. You should be able to set a cue point in one of the Native Instruments sample tracks. Might be an idea to see if you can set a cue point in one of those first actually. Apologies if you've already tried all this!

Back To Top