S88 Mk3 - Firmware Update Failure

lasynth
lasynth Member Posts: 2 Newcomer

Hi, all. Finally got my S88 Mk3 (after waiting 3 months) and the Firmware Update continually fails. I opened a support ticket, but can’t find access to the ticket on the NI site. It appears their ticket system is one-sided and meant only for NI’s information.

Note: the reply email from NI support does not include a working link to the referenced ticket.

I hope I’m wrong and it’s only bad UX that’s preventing me from finding my open ticket. Does anyone know how to access an open support ticket?

I bought this controller thinking I was going to commit to the NI ecosystem, but so far that appears to be unwise.

Any guidance would be appreciated.

Thanks in advance.

Tagged:

Answers

  • Uwe303
    Uwe303 Moderator Posts: 2,904 mod
    edited February 5

    Or this: (sorry can't send 2 of those links in one post from my cellphone in one post) what system do you use, have you installed all windows updates if you use windows.

    https://support.native-instruments.com/hc/en-us/articles/14229160390045-Kontrol-S-Series-MK3-Troubleshooting-Firmware-Update-Issues

  • lasynth
    lasynth Member Posts: 2 Newcomer
    edited February 5

    @Uwe - Thank you and yes I have, and numerous others.

    Ive tried everything from from switching ports, to switching cables, reinstalling all the relevant apps through Windows and Native Access. Ive tried adding power, connecting directly through the PC and via a USB Hub, updating drivers, editing drivers, using a different computer (PC - I dont have a Mac laying around).

    When the S88 Device disconnects during FUpdate, it's replaced with an "Other Device" with NO driver which throws a "incorrect hash" error when trying to update it.

    Ive tried everything that I've come across and no go so far.

  • BIF
    BIF Member Posts: 425 Pro

    Hi OP.

    Please describe the data AND power connections you're using during the firmware update attempts. Please include EVERY device in the chain, especially for the data chain...including any extension USB cables and/or USB hubs that may be in the chain.

    Type of cable, including connectors at the upstream (computer) end and at the downstream (device) end.

    This is failing because something is interfering with the signal.

    Or you have a wishy-washy PD (Power Delivery) cable or power supply. I recommend any new or old Apple or other wall-wart with USB PD...delivering no less than 20 watts.

    If power is ample and stable, then I'd guess it's happening on the data side.

    I've been able to update my MK3's firmware twice now, without issues...and by using a Windows 11 machine, not a Mac. I have a Mac, but didn't use it to update my firmware. So I know it can be done.

    Thanks.

  • BIF
    BIF Member Posts: 425 Pro

    I just saw that, thanks @Matthew_NI ! They got you working late tonight, huh?

  • Matthew_NI
    Matthew_NI Product Team Posts: 682 mod

    Ha! I get bored and can't help but log in... I also work crossover Berlin hours, but from Boston 🤣

Back To Top