D2 Waveform Display

Hi, I'm asking a question as a last resort because I cannot find an answer anywhere.

I recently bought 2x Kontrol D2s second hand to use with Stems files. Everything is working perfectly apart frpm the display on the D2s themselves, all the waveforms come up in purple rather than the 4 colour display.

Traktor has the waveform display set to Spectrum, and every demo of the D2 with stems I see on the internet shows the screens mirroring this. The Screen are definitely not faulty because they show colours in other options.

So far I have tried:

Updating Traktor to latest version - no effect

Updating driver the the D2s - no effect (there isn't a firmware update I can find)

Changing the waveform colour setting in Traktor back and forth - no effect

Pressing every key combination I can think of on the D2s - I can't see anything in the manual


It's like the D2s are stuck on Ultraviolet somehow with no ability to change them that I can find.

This is driving me absolutely nuts so can anyone help? Both D2s do the same so I'm sure this must be setting.


Pictures:


Best Answer

  • MonkeyBoyMorton
    MonkeyBoyMorton Member Posts: 2 Member
    Answer ✓

    OK, answered my own question in the end. I'm using a program (nustems) to create the stems file and that was adding the colours as all purple. As soon as I loaded one of the traktor sample stems files the colours worked.

    So it was to do with metadata and colours for each track. In case anyone else comes across the same issue.

Answers

  • MonkeyBoyMorton
    MonkeyBoyMorton Member Posts: 2 Member
    Answer ✓

    OK, answered my own question in the end. I'm using a program (nustems) to create the stems file and that was adding the colours as all purple. As soon as I loaded one of the traktor sample stems files the colours worked.

    So it was to do with metadata and colours for each track. In case anyone else comes across the same issue.

Back To Top