Scarlett interface bypassing External Mixer EQ Controls - Help

Marduk112
Marduk112 Member Posts: 3 Newcomer

Hi all. My issue is that while I am getting audio out of the Scarlett 4i4, it is at full EQ for every track on any and every channel, the audio output is unaffected by Xone 92 EQ'ing/mixing, and the audio isn't showing up on the level or master volume meters for Xone 92.

My setup is running Traktor to a single Xone:K2 (that controls Traktor), then through Audio 10 DJ, Xone 92 external mixer, and back out to Scarlett. I have connected an RCA to 1/4 cable by connecting the RCA end to Audio 10 main out and the 1/4 end to the "3-4" line input jacks in the Scarlett. Focusright and Traktor settings are screenshotted and attached.

FYI - I created an aggregate device of both Audio 10 DJ and Scarlett on my Macbook, and selecting either the aggregate device or Scarlett itself as the Traktor audio device yields audio out subject to the issue above, i.e. unaffected by EQ mixing.




Answers

  • lord-carlos
    lord-carlos Member Posts: 2,065 Expert

    From Traktor -> Audio 10 -> into Xone 92 .. and the xone output back into the scarlet?

    And when you monitor the scarlet anything you do on the xone does not make a difference? What output on the xone goes into the scarlet?

    Also you have mapped every deck to just output on channel 1 and 2? So every deck in Traktor goes just into a single deck on the xone. Is that on purpose?

    Is this some niche use case? Because it's not a normal setup.

  • zephry
    zephry Member Posts: 560 Pro

    This definitely seems like a strange setup. Expensive too. Why not just use a Traktor controller instead of all this?

  • Marduk112
    Marduk112 Member Posts: 3 Newcomer

    @lord-carlos Thank you for responding. I am new here but based on my cursory review of similar posts, you seem to be the patron deity of this forum, so thank you for taking an interest, it is very kind :)

    I basically added Scarlett to the rest of my setup so I could record mixes. If there is a less complicated way of achieving this result with my existing equipment, I am all ears.

    The issues I have not figured out are: 1) what output goes into the Scarlett 3/4 line input? Based on your comment, it sounds like it ought to be Xone 92 record out, but I am not sure.

    2) What Traktor settings (audio setup and output routing) will enable me to mix live on the Xone 92 + Xone K2 with EQ control, light levels, and all that on the mixer? I have changed the output routing such that output deck A corresponds with 3: Ch. A Left and 4: Ch. A Right, and so on, as shown in the embedded image, but still no output though Scarlett plus EQ control on the mixer.

    I know these are basic questions, so my apologies and thanks in advance!


  • lord-carlos
    lord-carlos Member Posts: 2,065 Expert
    edited January 21

    Ah ok. Yes it makes all sense now.

    The Traktor A10 has plenty of inputs, could you not use one of them for recording?

    Anyhow, I would try to minimize the setup just to get things working. We can add the scarlet again later.


    Do you want to control EQ on the k2?

  • Marduk112
    Marduk112 Member Posts: 3 Newcomer

    Thanks, Lord Carlos. After many more hours pulling my hair on it, it turns out a Mac update to the default privacy settings blocked microphone access from Traktor. Once that was sorted, your fix worked beautifully.

    For future troubleshooters, I have linked the solution below.

    https://community.native-instruments.com/discussion/9163/recording-mix-external

    In relevant part: "Choose Apple menu > System Settings, then click Privacy & Security in the sidebar. (You may need to scroll down.) Click Microphone. Turn access to the microphone on or off for each app in the list."

Back To Top