NI Effect freeze when close it

ParadigMan
ParadigMan Member Posts: 3 Member

Hi NI community, 

I use Maschine Software for my Live-Setup on a Win11 computer since many years and didn't have any issues. I also use to update Windows and all Plugins including NI Komplete 12, iZotope, Waves and Steinberg Plugins. 

Since some weeks I niticed, that loading a project can take up to 30sec, which is really awkward, standing in front of an audience. So I did several tests and found out, that the NI effect from the Komplete series crashes, when I close them (the build in effects in Maschine working fine). All other effects take less than 1 second to close, while a NI Komplete effects use up to 8 seconds. If I have 3 of these effects loaded, it takes 24sec to close the project. I also found out, that the problem is not the Maschine Software, because same issue with NI Komplete Kontrol. Ni Instruments are also working fine, only the effects like Driver, Dirt, Passive EQ, Replika, etc causing troubles.

Strange but true: On my laptop (HP ZBook Studio x360 with i7 8th Gen and Win11) I don't see the problem, its only on my Live-Setup PC (TAROX NUC with i7 10th Gen). Because I didn't see the issue with my NUC during the last 5 years, I don't beliefe, that it is a hardware issue. I also updated all the drivers, with no success :(

Than I made a plan: 

1) Search in the web and also here, but after some hours, I gave up, because no results 

2) Reinstall all NI Komplete software and plugin => did not help 

3) Rerinstall Win11 and all Software (took me many hours) => did not help 


Now I'm here completly desperate. How can I fix this? Avoiding these plugins could be a solution, but I don't like it. Does anyone else have the same or similar issues? 

Greatful for any kind of solution. 

Ben aka ParadigMan 

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,870 mod
    Answer ✓

    @ParadigMan When did that start to happen? Did you update some of these plugins lately? What graphic card do you have on your live Pc? Are you using the VS2 or VST3 NI effects?

    Open the plug-in in Maschine, expand the view fr the plug-in, if you disable (untick it) the Usage Data tracking for all of them and restart Maschine, does it get better?


Answers

  • geiger167
    geiger167 Member Posts: 26 Member

    Be easier to switch to native Ableton live effects for the time being wouldn't it :)

  • ParadigMan
    ParadigMan Member Posts: 3 Member

    @geiger167 Redesigning all my tracks and special effects with automation is not an option. But thanks anyways for the suggestion.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,870 mod
    Answer ✓

    @ParadigMan When did that start to happen? Did you update some of these plugins lately? What graphic card do you have on your live Pc? Are you using the VS2 or VST3 NI effects?

    Open the plug-in in Maschine, expand the view fr the plug-in, if you disable (untick it) the Usage Data tracking for all of them and restart Maschine, does it get better?


  • ParadigMan
    ParadigMan Member Posts: 3 Member

    WOW @Jeremy_NI ,

    This is the solution. Because my Live-PC was not connected with the internet, so the effects can not communicate with the server and the plugins freeze. Thank you so much for your help, you are my hero and I'm super happy with my setup again. I switched of the user data in the Native Access Application, because this disables the tracking of all applications and plugins.

    I did some tests:

    1) User data tracking enable, internet disconnected => Effect need around 8sec to close

    2) User data tracking enable, internet connected => Effect need around 2sec to close

    3) User data tracking disable, internet disconnected => Effect needs less than 1sec to close

    4) User data tracking disable, internet connected => Effect needs less than 1sec to close

    It is strange that NI try to communicate without internet and freeze (test case 1). Even with internet, it needs more time, so for me the implementation of the user data tracking is counterproductive for user. I followed the recommandation of NI to enable it to improve the product, but it makes the product worse.

    But again 1'000'000 thanks to @Jeremy_NI for your help, you made my day (and beyond).

    BEAT ON!

    Ben aka ParadigMan

Back To Top