Izotope login and account access not working

IamSavoii
IamSavoii Member Posts: 8 Newcomer
edited January 12 in Other Software & Hardware

I made a purchase today via the Native Instruments website for a Izotope product, RX 10. Infact, Native Instruments sells MANY Izotope products on their website.

When you make an Izotope purchase from NI, you get a few emails from NI. You get your order confirmation and you get your Izotope product serial number. You are then directed to the Izotope website to setup an account with Izotope and to download your product using the serial number provided by NI, using Izotopes Product Portal software.

Well guess what? The Izotope website is broken. It won't let you login if you already have an existing Izotope user/pass login and it won't let you register to create a new one! What else? The Izotope Product Portal software (that NI tells you to go use to get your new shiny fancy software) doesn't work either because it has to access the same database of user accounts as the website! You can not login to Izotope at all to download your software. Can't login or create a new user on their website and the Product Portal won't connect (you can't login using it either). So you are stuck in the most frustrating situation of having paid A LOT of money to trust a company to provide you with what you paid for but you don't get it. You don't get anything. You don't get any answer back either. I've tried everything, resetting password, tried registering a new user, and sending a lengthy support email, NOTHING WORKS!

After this happened to me, I googled it and guess what? This has happened many times before over many MONTHS with Izotope. Really? You STILL can't fix it?

Two separate companies with thousands of people working at them, generating millions of dollars but you can't manage a simple user account management database, online system? There are FREE plugins and instruments with better online account access systems that actually WORK!

WHAT THE HECK IS GOING ON WITH NATIVE INSTRUMENTS AND IZOTOPE!??!

I am so pissed that this happened and that I have to work through a giant issue on their end to simply get what should be super easy. And that is the best case scenario! I hope I actually get it!!! I still don't know if I will ....

Native Instruments, some advice: TAKE DOWN ALL THE IZOTOPE PRODUCTS FROM YOUR WEBSITE IF PEOPLE CANT ACTUALLY DOWNLOAD THEM!

You will take my money and then not provide a product! Shame. Shame on you. And I thought NI was a reputable company. Izotope is NOT the only one looking really bad here.

In this industry of online accounts and downloads being common place, this FAILURE is pathetic AND 100% preventable.

Provide a solution before you piss off more people!

Give me my software!!!!

Comments

  • Simchris
    Simchris Member Posts: 184 Advisor

    so, you cannot download the izotope product portal installer app and enter serial number to activate and install?

    https://support.izotope.com/hc/en-us/articles/6658125027345-Welcome-to-iZotope-Product-Portal

  • IamSavoii
    IamSavoii Member Posts: 8 Newcomer
    edited January 12

    I can download the product portal. It just won't connect to any user database to allow me to login. I thought that was pretty clear in my message.

  • IamSavoii
    IamSavoii Member Posts: 8 Newcomer

    Native Instruments or Izotope please respond with a solution.

  • PK The DJ
    PK The DJ Member Posts: 845 Guru

    It's all working OK here. Windows 11 using either Firefox or via the product portal.

  • IamSavoii
    IamSavoii Member Posts: 8 Newcomer
    edited January 12

    Im using Windows 11 fully updated. I have tried Chrome AND Edge to logon to their website and with my phone running google android/Chrome web browser and I can not login nor can I click on the create new user/register new user link on either Edge or Chrome from my Windows 11 without getting various errors. I even turned off Windows Defender firewall, still no go from either web browser. I have NO other virus/security software, etc. I have several screen shots of errors from both trying to login on the website AND trying to connect using the product portal.


    Mind you I do A LOT of music related product portals and websites, etc for plugins and instruments. I have all the major ones setup like Native Instruments (works fine, Ive downloaded various instruments from them), Arturia, UA Connect, iLok, UJAM, Softube, Spitfire, Steinberg, Toontrack, Plugin Alliance. They all work except for iZotope.


    Product portal version iZotope_Product_Portal_v1_4_8.exe will not connect either. Which is what matters because that is where I can actually download the product I paid for!


    There is an issue with their user account database, apparently not for every customer, but I can verify that I can not login to website, nor can I login through product portal.


    Fix it now please.

  • IamSavoii
    IamSavoii Member Posts: 8 Newcomer
    edited January 12

    Native Instruments AND iZotope, reach out to me directly and I will provide you my account info. Maybe your system is just corrupted and broken with my account.


    That doesnt explain why there is a history of this issue happening with iZotope online, when ALL the other companies have seamless product account purchase software solutions.

  • IamSavoii
    IamSavoii Member Posts: 8 Newcomer
    edited January 13

    Update: I still cannot log in with my original user account that I have set up with native instruments onto the iZotope website or product portal which means I cannot download the product which I purchased through the NI website. This still has not been resolved. it is a hot mess and nobody can fix it.

    I have since been able to create a different user account with Izotope directly which allows me to log in to the website and download free products and trials (and anything else I purchase, THOUGH I ALREADY PURCHASED IT THROUGH NI) through the product portal. However I cannot transfer a license or serial number from the Izotope account that my purchase was assigned to through the NI website purchase.

    If you go to the NI website and you go to transfer license, guess what, it does not show Izotope products. Yeah that's right so you can't even transfer an izotope product that you purchased from NI. You can only transfer NI products to other NI accounts.


    So I am still stuck without the purchase that I made through the NI website of an Izotope product.


    I have heard from I believe it was in Izotope customer service rep through the email contact system they use but all he did was point me in the direction of the troubleshooting links on their website.


    Complete ****** they don't want to fix it.


    Bottom line make a purchase directly through iZotope website and/or with the product portal and make sure your account is set up and working, download a free Izotope product, etc. Do not buy an Izotope product through the NI website and have them automatically set up an account through iZotope for you because it will not work and you will be locked out of the purchase that you made.

  • PK The DJ
    PK The DJ Member Posts: 845 Guru

    Log in to iZotope with your iZotope username/pw then add the serial number of your purchase to your account there.

    Your NI account is your NI account. Your iZotope account is your iZotope account.

  • IamSavoii
    IamSavoii Member Posts: 8 Newcomer
    edited January 16

    Obviously PK the DJ did not read or understand the post. Disregard his comment. That has already been covered in detail.

    iZotope still has not provided me access to my iZotope account and I still CANNOT download the product that I purchased through NI.


    For the PK the DJs types out there, I will lay it out for a third time. When you purchase iZotope products through the NI website, you get a bunch of correspondence from NI. Order info, serial number, billing, etc.... One of the emails you get states that the email you used to make your purchase on the NI website will be associated with your SN (product download) from the iZotope website. SO, if you can not get access to that iZotope account because their user account access software management database system will not allow you to login, reset your password, will not ALLOW YOU ACCESS AT ALL, and it gives you multiple errors, just trying to login, then that product you purchased is locked, and gone because it belongs ONLY to that user that NI established with your purchase.


    I have been able to (I said this all before btw) to create a new account at iZotope, BUT IT WILL NOT LET ME USE THE SERIAL NUMBER for the product I purchased BECUASE IT IS LINKED to the original account that NI established with my purchase.


    If they can't give me access to the iZotope account (I can't login, I can't successfully reset password, I get various errors on their website and via the product portal with that user) then they have to transfer to the new account that I set up with iZotiope that actually works (logs in without multiple errors) OR they have to refund me. Neither of which has happened. I have stated this information with iZotope, but have NOT gotten a response. The last email I got from said something to the effect of "I see the problem you are having and I will escalate it to our technical team". No actual resolution.


    It's a completely unnecessary, WAY TO ****** AND COMPLICATED problem to have ON THEIR END and there is NOTHING I can do until someone actually steps up from either Native Instruments OR iZotope.


    Again, transfer my purchase to the new account I set up at iZotope that works, releasing that serial number from the corrupted, dysfunctional original user account that wont work OR refund me my money so I can make the same purchase with the iZotope account that actually works, that you wont transfer to (logins both to the website and product portal).


    I don't need more ignorant comments from the peanut gallery because if you cant read all of this and understand the issue, just keep on moving.


    I need iZotope and/or NI to actually solve their own issue but if I have a lesson to teach the peanut gallery, its that you SHOULD NOT BUY iZotope from NI. It has inherent user account/erial number management problems, that they continually have issues with and don't address with permanent fixes. Just go look it up online, google it.


    Buy direct from iZotope, not through NI.


    Now give me my software!

  • Jean-Christophe J.
    Jean-Christophe J. Member Posts: 2 Newcomer

    I had the same issue, the problem is that for Izotope and native access, I had two different passwords. As you have to sign in trough the same gate for both accounts, it is a problem.

    This is how I could solve the problem :

    1. make sure you can login to "native instruments" and save/copy the native instruments password
    2. go to izotope login and follow the "forgot password" procedure.
    3. Click the link received by e-mail and PASTE the Native access Password.
    4. You should be good to login in both izotope and Native access.
  • andypow
    andypow Member Posts: 1 Newcomer

    Wow! No response on this?

  • PoorFellow
    PoorFellow Moderator Posts: 1,665 mod

    IamSavoii has not been active here since January 17 and might have resolved the issue through customer service. I am just another made Moderator and not working for N.I. I have no insight in any such things. Also , this forum is mostly user helping user. There are N.I. staff and even a N.I. customer care person that also acts as a liaison to customer service (when not absent and on leave as at the moment). There are even N.I. product managers visiting the forum and participating to some extend. So my guess is that IamSavoii just didn't found it necessary to report back when he got a resolution whatever that was , things working or a refund !?

Back To Top