S49 Mk3 won’t reboot after successful firmware update

Soundtrackk
Soundtrackk Member Posts: 4 Newcomer

Hey community,

it’s seems I’ve run into quite the issue:

after reading forums and discussions on here, I carefully installed the firmware update to my S49 Mk3. The firmware successfully installs, but when the controller goes to reboot, it never starts back up, and seems like it is bricked.

I purchased one of these a few weeks ago, and read that I may have fault equipment from firmware damage. My issue is that I scheduled a return to the seller, and went ahead and ordered another one so I could get to work (support for MK1 has went poof so it was time to upgrade). The new one arrived today, so naturally I went to set it up.

Boom, same problem. The updater registers that the firmware was installed successfully and is “waiting to reboot”. When it shut off to reboot, it never rebooted. It seems like it is bricked, just like the first one. It won’t even power on.

ive tried a separate power supply, different ports into my Mac M1 studio, tried to hit the power button 5 times to enter recovery mode, nothing seems to work.

granted I’ve been using the supplied usb cable which I’ve read is an issue, and I tried to use my USB-C power supply from my iPad Pro to see if I could get it to turn on. Nothing is working and with this being the second one in a row not rebooting after it stated that the firmware update was successful, I’m very frustrated.

been with NI for a very long time and I love what they have to offer, but man this is a bummer.

does anyone have any advice? Is this truly a hardware issue? Could a particular USB-C cable supplier work?


just very distraught and frustrated. Sitting with two keyboards in my studio that seem completely bricked. Any help would be very much appreciated.


Comments

Back To Top