Kontakt plays every loaded instrument at the same time.

Solarfall
Solarfall Member Posts: 8 Newcomer

Somehow, Kontakt is triggering every instrument at the same time. I haven't encountered this issue before. I want to play only one instrument at a time. I've been using Kontakt for years and I am familiar with routing inputs and outputs, splitting channels, etc. Initially, I thought it was an issue with my DAW, Cakewalk. However, I tested the same scenario with another DAW, Reaper, and encountered the same results. Any ideas on how I can resolve this issue? I'm using Kontakt v6.8.0.

Best Answer

«1

Answers

  • Milos
    Milos Member Posts: 1,867 Pro

    Try this alternative:

    Use Host Automation to host the S and M buttons.

    When you want to hear the first instrument only, silence the second instrument with the automation, and vice versa.

    Or try the alternative of the first alternative:

    Use host automation for the volume, so that when you wanna hear the first instrument, use the volume host automation to silence the other instrument.

    Let me know if it helped.

  • Solarfall
    Solarfall Member Posts: 8 Newcomer

    That's a nice workaround, but it's not an actual solution. I might have done it if Cakewalk were to support Python scripting, as doing this automation for every track I create would take a considerable amount of time. I want to figure out if my copy of Kontakt is somehow damaged because if I'm the only one experiencing this strange issue, I need to contact support.

  • Milos
    Milos Member Posts: 1,867 Pro

    I will explain it to you tomorrow how can you do it with couple of screenshots, i am going on a school vacation to Turkey.

    When I come to the hotel, I will screenshot the solution.

  • Solarfall
    Solarfall Member Posts: 8 Newcomer

    Thanks for your help! By the way, I'm from Turkey :) Looking forward to your screen captures.

  • Milos
    Milos Member Posts: 1,867 Pro

    Oh, nice!

    Expect the screenshot explanation by either tomorrow or 2 days!

  • Milos
    Milos Member Posts: 1,867 Pro
    edited January 8

    Btw, do you usually use Cakewalk for Kontakt?

    Just to be sure.

  • reffahcs
    reffahcs Member Posts: 801 Pro

    That's how it's intended to work. Whatever instruments are loaded in the rack will all play at the same time.

    You can solo an instrument just like in most DAW's and that will mute the rest. Alternately you can mute specific instruments and play multiple other instruments.

    Not sure this is the answer you wanted to hear, but this is how it works currently.

  • Solarfall
    Solarfall Member Posts: 8 Newcomer

    Thank you for your answer! It's strange since I've composed countless songs in Cakewalk. I've been composing music since 1999, so I've seen many things :) I used Kontakt 3 back in the day and then switched. I bought a new license for Kontakt 6 a year ago, and I was very happy until now. The behavior you mentioned is odd because it goes against the logic of separating channels and routing them to their separate outputs. While recording a few tracks, I didn't have to solo or mute the channels in my DAW; Kontakt handled it automatically. That's why I find this behavior strange and counterintuitive.

  • stephen24
    stephen24 Member Posts: 259 Advisor

    but this is how it works currently.

    Don't think so. (Unless all are set to the same channel or omni, like your 2nd instrument.)

    I think there are only 2 possibilities

    1. Something bizzare from your MIDI controller or MIDI sequence - it would have to be sending multiple messages for each note - each on a different channel. Hard to envisage but you could detect this with a MIDI monitor. (The one in your DAW would probably be better than the Factory multiscript if it can display more than one event at a time).
    2. A rather unusual bug in Kontakt which would probably mean you need to reinstal it. Does it happen in the standalone version?
  • reffahcs
    reffahcs Member Posts: 801 Pro

    I tested it using the default settings that Kontakt gave me, I didn't assign anything or change any of the stock settings. Perhaps in previous versions it would automatically assign each instrument in a rack to a new MIDI channel? Or there's a menu setting that you can enable to have that done automatically?

  • reffahcs
    reffahcs Member Posts: 801 Pro

    To clarify what stefan was alluding to, apparently you can actually change the MIDI channels per rack instrument. As I mentioned, I'm not sure if this used to happen automatically in older versions, but I suppose it doesn't matter now.

    To assign an instrument to a specific MIDI channel, click on the i button, then click next to MIDI CH, it will say Omni by default. Change it to whatever channel is appropriate.

    I would have mentioned this earlier but I only figured it out after seeing stefan's response to my post.

    Hope this works for you!

  • reffahcs
    reffahcs Member Posts: 801 Pro

    I found more information while searching for a fix for a different problem. There is a menu setting that you can change so it will automatically assign each rack instrument to a different MIDI channel automatically. By default it's set to Assign to omni. But you can change to to Assign first free, if you'd rather not have instruments all on the same channel.


  • Solarfall
    Solarfall Member Posts: 8 Newcomer

    youtu.be/AW0Cz_p0QT4

    I just tried this YouTube tutorial, which is what I've been doing since I already knew these by heart but I gave it another shot anyway. The result he got in this video is the opposite of what I got. He triggers channels based on his setup done in Cakewalk but when I do the same, all the channels in Kontakt get triggered. I reinstalled Kontakt from the native access app but no luck.

Back To Top