Can’t access updates for Traktor Pro 3 11.0

Dj Mikyg
Dj Mikyg Member Posts: 4 Newcomer

Hi i cant install the current Native access program due to the error of please give permission to native access. I have tried all the thing mentioned on the forums aswell as the demon tools install but still get the same error.


i have managed to install an older legacy version of Native access which allowed me to finally intall Traktor 3 but it isnt showing the update to 3.11. I have downloaded the beta which allowed me to install the beta but how do i go about keeping up to date?

Best Answer

  • lord-carlos
    lord-carlos Member Posts: 2,053 Expert
    Answer ✓

    Mhh, I would try to contact support. No need to mention traktor, just tell them you have trouble installing NA.

Answers

Back To Top