Midi Mode with Studio One.

Royster64
Royster64 Member Posts: 21 Member

Hi Guys. I recently purchased Maschine Mikro Mk3. I am sure I will get great use from it eventually, once I have familiarised myself with all the functions, but I did hope I could use the Pads with Studio One with 3rd Party Drum programmes like SSD5,Drunforge and EZdrummer. I have tried it in midi mode and I am certain the device is set up correctly but I can't seem to get any sound out of it. I did manage to create a kit via midi learn in SSD5, which worked with the pads but could not get it to record in S1. I feel I may need to create a template of some kind in Controller Editor but as an intermediate music producer with limited experience with NI products, I am a little lost. Any links to ready made S1 templates,Videos or hopefully another S1 user who has solved the puzzle. I would be very grateful. I can play any drums with Kontrol A25 no probs but I like the idea of using the pads. I am using the current version of Studio One 6Pro on Win 10 64bit.🙏

Answers

  • D-One
    D-One Moderator Posts: 2,748 mod
    edited January 4

    Some of those Drum Instruments have ways of MIDI Mapping inside themselves with MIDI Learn so you can just use that + the default MIDI Controller Editor template for Mikro MK3.

    Or... You can do it the other way around: Create Controller Editor templates for what notes each instrument expects... Either read their manual and just do trial an error. There's not much to it, just select the Pads and change what note they trigger.

    Alternatively, you can just use the Group Change combo (Group+Pad button) with the default template, it changes octaves, so just use that to find the right octave that triggers the instruments, just like your keyboard.

  • Royster64
    Royster64 Member Posts: 21 Member

    Hi. I really appreciate your response. I have tried all the group pads with no response, as I mentioned, the closest I came to something working was when I created an entire kit from SSD5 as it has midi learn. I saved it and managed to load it after shutting it down. It plays but I can't get it to record within Studio One. I hit record, make a beat but the screen is blank when I hit stop. It is probably something simple I have missed but everything appears to be set up as it should be.

Back To Top