Suddenly no sound from Kontrol S2. Macbook M1, Traktor DJ software.

NILIN
NILIN Member Posts: 2 Newcomer

Earlier today I was successfully using my Kontrol S2 with headphones, connected to an external amp/speaker. I unplugged my MacBook from the controller and charger to use it elsewhere for email and stuff. Switching off the Kontrol S2 and speaker.

Later on, I plugged back in but I could not get sound out of the S2 at all. Not from headphones, not from main. The controls work and it lights up as normal. Sound output in Traktor DJ software is routed to the S2 as it should be, as it was earlier. I've tried unplugging it, unplugging power from it, tried a different USB adapter. Rebooted the Macbook Air, and nothing

Is there some kind of hard reset I can do on the S2?

I have installed only Traktor DJ software, no drivers.

Answers

  • Uwe303
    Uwe303 Moderator Posts: 2,911 mod
    edited December 2023

    Hello,

    have you tried to output your mac sound through the s2 just to test it with e.g. yt? You would have to set it as output device in mac prefs i guess. Maybe you can also post a picture of the output settings mac and traktor.

  • NILIN
    NILIN Member Posts: 2 Newcomer

    @Uwe303 Yes I have tried that. No sound with that method, either. Thanks for taking the time to reply!


    Update: It's an S2 Mk2. I have tried with Traktor Pro 3, Traktor DJ 2, and checked with spotify/youtube via the mac settings on 2 different laptops (Macbook Pro M1 Max and Macbook Air M1, both with MacOS12.1 Monterey) and also on iPhone with Traktor DJ. No dice. Controls work (if slightly poorly assigned) but no sound from any output.

    I had it working previously and am using the same settings everywhere, I had no trouble at all getting it work the first time, to its credit, it's basically plug-and-play as the software recognizes it immediately. I'm fairly convinced it's a hardware problem or something in the firmware of the S2. I have, however, tried updating the firmware to the latest one, and it didn't help.

    If I can't get it to work with some software-based reset I'll have to open it up and see if I can find a blown fuse or other component. There's a slight chance I'm using the wrong power supply, the one I am using has a slightly higher power rating than is needed, but the voltage is correct. My feeling is that on startup, the S2 may have drawn more current than it needed and popped a cap or something.

    Oh and to further my frustration, I could feasibly have used it just as a controller and routed the audio from my Traktor Audio 2, but lo and behold that's no longer supported, leaving me with another expensive paperweight.

    My stop-gap solution is a headphone jack splitter for dual mono output. Dutifully bought the Traktor one off Amazon, should arrive any day now. (^^;)

  • Uwe303
    Uwe303 Moderator Posts: 2,911 mod

    If the voltage is correct and polarity, then the power supply will work. As you describe it with all the tests and no output at all, I fear that the hardware is somehow defective. The S2 MK2 is compatible with M1 as far as I found out. Maybe you have a friend with a windows PC and you could try there but then you need a driver. Otherwise, as you already pointed out, you need another interface.

Back To Top