I cannot open a lot of instruments after update

MikeJ
MikeJ Member Posts: 4 Newcomer

Hi I ran "update all" in Native Access and now I cannot run a lot of instruments they just fail to load saying that "Your version of Kontakt is too old to load this file, which was saved with Kontakt v7.7.0.000."

I can see in Native Access that I have Kontakt 7 Player v7.6.1, and Kontakt v6.8.0 installed and there is no option to update either of them.

I have Komplete 13 and a Komplete Kontrol S88 MK2 keyboard.

Answers

  • indrawan_henri_99
    indrawan_henri_99 Member Posts: 29 Member

    maybe you should reinstall like deleting all files plugins, go to help then uninstall plugins first, then uninstall native access all, then install them again

  • mykejb
    mykejb Moderator Posts: 831 mod
    edited December 2023

    You should see the update options, are you using Native access 2 or the older NA1? You can always get the older versions of the libraries which work with the older versions of Kontakt. Links are here - Previous versions of recently updated Kontakt libraries / compatibility with K6 older libraries — Community (native-instruments.com)

    -- Mike

  • MikeJ
    MikeJ Member Posts: 4 Newcomer

    This is helpful. I did not know there was a Native Access 2, I just updated with what I assume was version 1 installed already on my machine. I have now updated to version 2 and I have the download for Kontakt 7 Player available.

    However I now have another, much worse issue! I updated everything using Native Access 2 and then all my projects have empty instruments because Ableton cannot load the VST2 plug-in for Komplete Kontrol. Seems that there are many people with this issue on the forum here! I followed the instructions to downgrade to Komplete Kontrol 2 by running the installer linked from this article: How-to-Keep-Komplete-Kontrol-2-9-VST2-and-Komplete-Kontrol-3-VST3-on-Your-Windows-System

    However now Ableton just crashes when I try to open a project! I managed to start it once without crashing but it still said the VST2 plug-in cannot be found, and when I added a new midi track and added Komplete Kontrol plugin there it crashed Ableton again. I currently cannot work on any of my projects this is disastrous :/

  • mykejb
    mykejb Moderator Posts: 831 mod

    If you install KK3 it removes the old version (including the VST2) then installs the VST3 version.

    The old 2.9.6 version is here Komplete Kontrol 2.9.6 - Last VST2 supported version — Community (native-instruments.com) and if you don't have a MK3 keyboard the general opinion is it's best to stick with this version. I had no luck installing both KK2 and KK3 at the same time so I stuck with KK2 on my main machine.

    -- Mike

  • MikeJ
    MikeJ Member Posts: 4 Newcomer

    Yeah this is the link I downloaded Komplete Kontrol v2 from. I have uninstalled Komplete Kontrol, and installed v2.9.6.

    I have Komplete Kontrol.dll present in both C:\Program Files\Steinberg\VstPlugins\Native Instruments and C:\Program Files\Native Instruments\VSTPlugins 64 bit

    I have ScanPluginsApp_x64.exe in C:\Program Files\Common Files\Native Instruments\Komplete Kontrol

    However Ableton still says it cannot load the VST2 plugin. If I look at all my plugins in ableton it has two sections VST and VST3but Komplete Kontrol only exists under VST3

  • MikeJ
    MikeJ Member Posts: 4 Newcomer

    Ableton just crashes whenever I try to load the VST3 plugin also :/

    This is very very bad, the entire suite I paid a lot of money for is completely unusable now...

Back To Top