Access Violation issues for all installs, after BSOD while installing Maschine 2

RvGeel
RvGeel Member Posts: 7 Newcomer
edited December 2023 in Tech Talks

While updating Maschine 2 to the latest version using Native Access, my new PC (i9, Windows 11 Pro) gave a Blue Screen of Death, blaming bomemidi.sys:

When I retried to install Maschine 2 after the reboot, it would never finish.

When I tried to install it directly by executing the .exe in the download folder, a series of six Access Violations show up, at the moment the installer is installing the Controller Editor.

All six are write access violations. When I click OK on all warnings, the installation completes and the tool works, but now I can't install any tool from Native Access anymore, because they all hang at the same point (and Native Access doesn't show the install dialog).

I tried without Antivirus, without Firewall, without keyboards connected, etc. but the result is the same every time.

I also tried to deinstall the Controller Editor via the Apps window in Windows Settings, but it won't let me:


When I try to manually install the Controller Editor (by executing it from the Windows Download folder), I get the following message:


How can I resolve this, so the installation runs without errors?


Thanks!!

Answers

  • PoorFellow
    PoorFellow Moderator Posts: 1,575 mod
    edited December 2023

    Try removing all the NI apps first by using uninstall in Windows if present, then remove remnants by using the NI reg tool . Then reboot computer , then try the installations !

    If that fails to clean sufficiently then try using the Forced Uninstall function in Revo Pro trial.

    Also, if you want to be able to reverse anything done then always make Windows system restore points manually prior to any installations or tinkering ! Having a full system drive backup taken when your programs works doesn't hurt either !

  • RvGeel
    RvGeel Member Posts: 7 Newcomer

    Thanks a lot for your suggestions @PoorFellow !

    I went back to a restore point which I created just before installing the new version (restoring takes a long time, I found out). It unfortunately didn't solve the issue.

    It turned-out that the crash corrupted some files of Controlled Editor and that the version that Native Access wanted to install was an older version than the one installed on my PC (for a reason I don't understand; maybe they rolled-back a version...).

    What did the trick in the end, was going to this hidden directory on my PC:

    There were these files:

    I then manually deleted all of them and downloaded the latest installer from here:

    Then ran the installer manually and that fixed it.

    I'm really happy that this got resolved, because now I can use Native Access again to install updates...

    Thanks all for the help!!

  • PoorFellow
    PoorFellow Moderator Posts: 1,575 mod

    Thank you for the feedback. Yes ! , cleaning out the hidden files also is necessary if you want to clean. Now you just need to make a backup of your system drive , while it all works fine I mean ! (so that you can always just load the latest backup if something like that ever happen again) ๐Ÿ˜‰ ๐Ÿ™‚

  • RvGeel
    RvGeel Member Posts: 7 Newcomer

    Absolutely! Will do that right-away!

    Thanks for the help!!

Back To Top