Kontakt 7 (Player) Won't open any instruments (flashes a white file briefly)

Memorymoog
Memorymoog Member Posts: 3 Newcomer
edited December 2023 in Kontakt

Hello All,

Hoping some kind soul can help after hours and hours of frustration trying to get this to work!

Yesterday, I (re)installed Kontakt 13 and some old paid for libraries onto a brand new machine.

I downloaded all these files/instruments from Native Access, entered the relevant serial numbers into Native Access and pointed all the Content Directory in Native Access towards those libraries.

They all show up in Kontakt 7 (Player), but when I select 'open containing folder' and select any of the instruments (.nicht file), a blank white file momentarily flashes up to the right the instrument rack sits, and nothing else happens.

I've tried installing, reinstalling, re-entering serial numbers, googling, everything but am totally stumped! These libraries still exist on my old machine, in case this makes any difference.

Any help would be VERY gratefully received!

Cheers

Answers

  • Milos
    Milos Member Posts: 1,833 Pro

    Kontakt 13?


    You mean Kontakt 7, right?

    As for the issue, maybe try to open the library or an instrument via Files, not with Library (you need Rack View for that).

    Then search for the instrument's paths and try to open them that way.

    Hope it works.

  • mykejb
    mykejb Moderator Posts: 817 mod

    Mac or PC?

    Do you see the products showing as "Installed" under Native Access? If so, check that when you click the three dots to the right and click "Installation Paths" that the correct location is shown. If the products aren't showing as "Installed" what does the button label say? If it says "Install" click it. If it says "Repair" click it and you'll get options to Relocate or Reinstall. If you have the product on your disk click "Relocate" and put the correct location in the box that pops up. If you don't have it on your disk click "Reinstall". Once you get to NA saying "Installed" it should show in the browser and library list when you open Kontakt Player.

    -- Mike

  • Memorymoog
    Memorymoog Member Posts: 3 Newcomer

    Thanks Milos and Mike for coming back to me.

    @Milos. Unfortunately this didn't work/no difference :-(

    @Mike - Thanks, yes, all showing as installed in Native Access and the installation paths for both instrument (application) and sounds content are both pointed in the right direction and showing as correct. Still not opening when the .nicht file is double-vlicked/selected.

    I have since realized I was too quick to update to Sonoma and that Kontak is not yet guaranteed compatible with that operating system. It was however working yesterday on first installation until a Mac pop up came up saying there wasn't an application to open it, so could well be a compatibility issue. I've tried to looking to see if there is any easy way to bring this (2023 M2 Pro Mac mini) back to Ventura, but it seems that Mac Recovery will only take it back to a fresh install of Sonoma :(

  • mykejb
    mykejb Moderator Posts: 817 mod

    @Memorymoog Kontakt is working ok on my test Mac with Sonoma. Does Kontakt have access to the folders containing Kontakt libraries? If they're on a removable disk that might be the problem. On my system Kontakt has access to "Desktop Folder", "Documents Folder" and "Removable Volumes" in the Privacy and Security section of System Settings.

    -- Mike

  • Memorymoog
    Memorymoog Member Posts: 3 Newcomer

    @mykejb - thanks agin Mike. Not that either, looking at the settings - they're all selected to on.

  • mykejb
    mykejb Moderator Posts: 817 mod

    @Memorymoog Do the instruments load if you use the browser rather than the library view? Do you get any error messages?

    -- Mike

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Memorymoog Kontakt should have full disk access: How to Enable Full Disk Access on macOS

    To load a Kontakt instrument, you should not use "open containing folder", this opens the Finder, that's all it is supposed to do. You should only click on Instruments and then load one of the nkis when in rack view:

    Or click on the presets when in Library mode:


Back To Top