Why does sound drop/skip at times when using Kontrol X1 MK2?

Jim
Jim Member Posts: 4 Sine

I recently purchased a new Mac and now the sound drops/skips at times only when using the Kontrol X1 MK2. All drivers/software is up to date. All. components work great except for when using the Kontrol X1 MK2. Note, I never had this issue on my previous Mac with a different OS. Any help would be greatly appreciated.

Set Up:

MacOS Big Sur 11.6.2 with 2 GHz Quad-Core Intel Core i5

Traktor Pro 3 LE

Kontrol X1 MK2

Pioneer DJM 750 External Mixer

(2) Pioneer CDJ 850

(2) JBL Eon 612


Installation:

Mac connected to external mixer via usb

Kontrol X1 connected to Mac via usb

CDJ's connected to external mixer via RCA

Speakers connected to external mixer via XLR

Tagged:

Comments

  • Karlos Santos
    Karlos Santos United KingdomModerator Posts: 136 mod

    What happens if you disconnect the X1 and just use your track pad to control Traktor? Do you still get the skipping?

  • Jim
    Jim Member Posts: 4 Sine

    I don't get skipping when I disconnect the X1. Traktor on my Mac and all other devices work great when I disconnect the X1.

  • Jim
    Jim Member Posts: 4 Sine

    Traktor Pro 3 does freeze at the moment the X1 drops the sound. Any help resolving this matter would be greatly appreciated.

  • Stevan
    Stevan MIDIMember Posts: 237 Saw

    Tried swapping the USB cable?

    Tried using a different computer?

  • Jim
    Jim Member Posts: 4 Sine

    Recently purchased new Chroma USB cables. The issue went away for about a week and then came back.

    It works fine when using my old MacBook Pro.

    Thoughts?

Back To Top