Cannot get Kontrol X1 to work on new laptop/software

Options

I have a Kontrol X1, the first version that came out. I used to use it with a MacBook Pro on Traktor Pro 3. It still works on that laptop, but I migrated to a new laptop a while back.

My current laptop is a MacBook Air with M2. This is what I run Traktor on these days, mostly connecting to an S3 controller.

Today I tried using the X1 on this laptop and it does nothing on this laptop. No controls work at all, no buttons lit up (apart from when I first connect and there is a wave of color). I have checked controller manager and there is an entry for X1 but when I select that there no controls mapped.

I thought that support for NI devices was pretty much built in/standard, so I was surprised it didn't just work. I then tried getting latest X1 drivers for macOS but the installer failed.

Any thoughts about how I get this working on this new laptop? The hardware is 100% working on the older laptop, just verified this.

I did note that in the old laptop, when I select X1, there are entries for X1 in the In-port and Out-port, but not in the new laptop (just says None)


Comments

Back To Top