Cannot Upgrade to 6.5 and cannot downgrade!

endpop Member Posts: 6 Newcomer

I was trying to upgrade Reaktor 6 to 6.5 and my old Native Access was not showing the new update. So, I tried to update Native Access, only to discover that it too is not compatible with Windows 7. But I cannot seem to go back!

I uninstalled N.A. v2 and tried to run the installer for the old version downloaded from the support page.

But when I try to install it, it now fails. I've already uninstalled the latest version and cleaned up the temp files, but I keep getting this error message:


  • endpop
    endpop Member Posts: 6 Newcomer

    Is there a place to download the installer as "Native Access Setup PC.msi" ??

  • Monochrome
    Monochrome Member Posts: 931 Expert

    This page is the only place for downloading the Native Access 1 installer.

    Something is definitely borked. You could give this a try:

  • PoorFellow
    PoorFellow Member Posts: 1,110 Guru
    edited November 1

    Previous problems installing and re-installing Native Access have included that Native Access un-install did not clean enough so that it left remnants of the old installation disturbing the re-install of the older/newer version.. In case of trouble then make sure that no Native Access components are running in memory after an uninstall followed by a reboot. Also manually delete all left overs of Native Access and NTKDaemon from hard drive locations and also check if there are remnants in the Windows registry (please notice that you ought not meddle with Windows registry unless you both takes a manual backup and knows what you are doing) . An app such as Revo Uninstaller Pro's Forced Uninstall function could possibly help clean registry somewhat (Revo Uninstaller Pro got a free working Trial) (scroll down page and trial link will show on page upper part)

    Only after cleaning re-install old version !

  • endpop
    endpop Member Posts: 6 Newcomer

    Totally! V2 left stuff in the registry. I wound up using the NI Registry Tool (feel lucky I had a copy lying around). I ran it, picked Native Access from the pulldown, and cleared the remnants in the Registry. After that, I was able to downgrade to/reinstate NA V1 with no problems (except that it only shows 6.4 as the final for me).

    Sadly, the latest version 6.5 of Reaktor is not available to me, which is sad. But I will not upgrade a perfectly running computer to that bloaty Windows 10. I will stick to 6.4 and I will miss out on a few library items. Although I do have 6.5 running on my laptop. So if I make a track using it, I will render it out.

    There should be a link to that registry tool somewhere. It works without much fuss.

  • endpop
    endpop Member Posts: 6 Newcomer

    For reference, this is the tool I used:

    It's the easiest one to clean up old versions and remnants of stuff.

  • PoorFellow
    PoorFellow Member Posts: 1,110 Guru

    Yes, I were aware of the tool , but sometimes in the past it didn't clean sufficiently anyway and especially does not clean the hard drive..

    Anyway , then it appears as my advice have solved your problem !

    Thank you for at least providing basic feedback !

  • Paule
    Paule Member Posts: 1,328 Expert

    Upgrade your OS first.

Back To Top