Technical help please; dropouts only on automation

Leyton
Leyton Member Posts: 5 Newcomer

Technical help please:


Computer 


Windows 11

I9 13900k

128gb DDR5

1x2gb and 2x1gb NVMe

Babyface proFS

Ableton live (10)

128 buffer

44.1khz sample rate

24 bit depth 


Absolute dog performance from Kontak7, can’t even load a single instance of session strings 2 without issues.


The problem:


I’ve set up kontakt so that expression is on the mod wheel. The minute I automate that, the CPU spikes and causes a grainy distortion. Normal play is fine, but if I automate that parameter, I’m getting awful awful performance.


Babyface ASIO says 0/0 errors and I will try adjusting the buffer size however before I resort to that, I was wondering if anyone has any other ideas, because it doesn’t seem like a buffer issue and I want to keep real-time performance as I have live recording still to do.


The PC is relatively top teir, I’ve tried forcing ableton to run on performance cores only via processor affinity and this had sadly no effect. 


Again, normal performance and cpu ticks at 15%. The minute it’s asked to chance velocity layers and I automate mod1 it goes crazy. Shutting down and restarting seems to help briefly but it will always go to distortion eventually and ONLY on the automated sections. Drawing a straight line vertically seems fine but the min it’s asked to ramp up or down, the cpu seems to stress.


It’s driven me absolutely NUTS on my session today. It’s a fresh install as well, pretty much the first time I’m using it. 


User error? Suggestions? 


Help…. Please

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    Answer ✓

    @Leyton The Komplete Kontrol issue in this thread was a different one, I checked in his ticket, resetting Komplete Kontrol's database, uninstalling it completely and reinstalling it fixed the issue.

    I've contacted you by email so my colleagues can have a look in your issue.

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,441 Expert
    edited September 2023

    What keyboard model do you have?

    Does this only happen in Kontakt, have you tried any other plugins?

    What instrument is loaded in Kontakt?

    If you record the automation how does it look in Ableton, is it also looking poor? Any chance you can post a screenshot?

    I guess if the automation looks ok in the DAW then the issue would be within Kontakt.

  • Leyton
    Leyton Member Posts: 5 Newcomer
    edited September 2023

    Hi

    sonfar this issue has only been replicated in kontakt and on session strings 2


    the keyboard is a Novation Launchkey 88mk 3


    changing the dynamics to the mod wheel in setting and then recording any automation will usually cause the issue.


    the automation lanes are fine, I’m actually writing the automation after the midi notes are recorded, so the automation is written perfectly


    as soon as it gets to a point of automation, cpu goes crazy.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Leyton Does that happen with any other Kontakt instument when using automation? Can you recreate the issue in a tiny project, zip it and post it in this thread?

  • Leyton
    Leyton Member Posts: 5 Newcomer

    as I’m very new to Komplete14 and Kontakt 7 I’m not really sure which libraries to test the like for like functionality - is there another library with dynamics on the mod wheel? If so I’ll give it a try.

    For sure I’m happy to make a small session that exhibits the issue, along with a video showing the issue on my PC for context. Give me a couple days to double check trouble shooting my self (I’ve still got a few things to try) and I’ll get this to you.

  • Gee_Flat
    Gee_Flat Member Posts: 906 Guru

    Factory Orchestral has all dynamics assigned to midiCC #1(modulation).

    Also, there is a KSP preset called 'Midi Monitor' located at the top of the rack. It might help you to see that info.

  • Leyton
    Leyton Member Posts: 5 Newcomer
    edited September 2023

    Ok,


    things I have tried so far with no effect:


    adjusted processor affinity to restrict DAW to power cores only: no effect


    adjusted preload size to max in settings: no effect


    asjusted multi core settings

    1) off: no effect

    2)16: no effect


    again this absurd CPU usage is only occurring during automation of the modwheel controlling dynamics. I have no more than 6 patches running and at all points of automation only the CPU skyrockets and causes glitching.

    according to the babyface ASIO errors 0/0, so doesn’t appear to be a buffer issue at 128.


    abletons disk error is NOT showing so the SSD is keeping up with the requests


    I can’t attach a video which shows the video as it won’t allow the attachment type and I cannot zip from my iPhone as far as I know. I can’t attach the project file on a public forum either as it’s an ongoing project


    i think I will need to open a ticket for this as it doesn’t appear to be a simple setup/user error or something simple as I’d hoped.


    I can also see that other members have also posted a very similar issue (https://community.native-instruments.com/discussion/15127/crackling-using-mod-wheel-with-komplete-kontrol-in-daw) so the issue is not just with me by the looks of things. Further searches online are also returning hits but never with any solutions; just descriptions of the same problem - excessive CPU use on big.little architecture when using dynamic layers on the modwheel.


    I hope a solution to this is found quickly as so far the main reason I purchased this is not actually very usable and is disrupting sessions in a serious way.


    please can we continue to investigate this rather urgent issue

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    Answer ✓

    @Leyton The Komplete Kontrol issue in this thread was a different one, I checked in his ticket, resetting Komplete Kontrol's database, uninstalling it completely and reinstalling it fixed the issue.

    I've contacted you by email so my colleagues can have a look in your issue.

Back To Top