Piano release samples can't be editted?

Wristlock
Wristlock Member Posts: 3 Newcomer

Im using different NI piano VST's: The Maverick, Grandeur, Gentleman. They all have the same problem for me: in the upper register theres a very loud and long release stage after the key is up again. Theres almost no difference between keeping the key pressed and releasing the key quickly, as far as volume and length. I know theres some sound there on a real piano too, and this adds to the realism but imo its way too much. I adjusted the release samples bar in the anatomy section, but this doesnt seem to affect this higher register (or not enough anyway). Its almost as if theres an extra sample that gets triggered here, specifically for this purpose of added realism or whatever. Either way, Id like to get rid of it, or better yet: tweak it.

So then I dove into the editing section of kontakt 6, and I think I found the place to adjust it. I selected the group of a specific key (A#5 i think it was) which if I understand correctly should hold all the samples of that note. Then I went to the amplifier section, and opened the volume modulation AHDSR-envelope. Indeed there is a significant release stage here, so I just turned the release knob down. But then the following happened: I pressed the corresponding key to test it out and the release knob jumps back to its original position. This doesnt happen for any of the other stages (attack, hold etc) which I can happily adjust. Only the release stage does this, which annoyingly is the only thing I want to adjust.

I also tried the same for the 'zone' envelope but the same thing happens. I dont think I fully understand the relation of zone and group yet so I dont know what would be the proper place to do this, but so far both of them just jump back to full release lenght.

Any help would be great!

Tagged:

Best Answer

  • stephen24
    stephen24 Member Posts: 257 Advisor
    Answer ✓

    On a real piano there are no dampers on the strings at the top octave or so, so releasing the key has no effect at all. If you wanted releasing the key to artificially shorten the sound, you could modulate the release time (itself artificial) with a constant and control it with the intensity slider. (To be truly realistic, the highest notes would have no volume envelope, but have a short sustain time intrinsic in the sample itself, and be programmed as a one-shot)

Answers

  • Wristlock
    Wristlock Member Posts: 3 Newcomer

    Ok so an update on my journey to fix this. The cutoff for the 'release samples' control in the main instrument page is D#5 for The Maverick (I havent checked the others yet). So the release time for D5 is still affected by the control and D#5 isnt. In the editting section there are also different release times in the AHDSR envelope for both notes. D5 is just right of center, D#5 (and anything above) has the full release length. If the 'release samples' bar is all the way down, there is an unnatural absence of release for all the notes up to D5, but then D#5 and up still have this giant release time that was unnatural to begin with! I'm really puzzled by this.

    At first I thought maybe Im not able to adjust the release knob in the AHDSR envelope because the 'release samples' control in the instrument overrides this. But adjusting the control doesnt effect the release knob in the editing section. Also from D#5 and up this control doesnt affect the sound at all, so Im not sure about this.

    I have however found a work around: I selected all groups for the notes from D#5 and up, went to the amplifier volume AHDSR-envelope and added a modulator for the release value. Im still nog able to ajust the basic setting of the release, but the modulator does work. I then selected 'velocity' as the modulator, actived the 'modulation shaper' (the knob with the little bar graph next to the 'invert' knob). I then essentially drew a straight line from left to right, so not modulating the value much at all. But now I am able to adjust the value of the release by pulling this bar all the way up (full release) or all the way down (no release). Having it velocity sensitive actually gives a nice option of having a slightly longer release for full velocity hits, adding to the realism.

    Anyway, it's a workaround so Im still curious how this should be fixed in a more proper way but Im happy for now.

  • stephen24
    stephen24 Member Posts: 257 Advisor
    Answer ✓

    On a real piano there are no dampers on the strings at the top octave or so, so releasing the key has no effect at all. If you wanted releasing the key to artificially shorten the sound, you could modulate the release time (itself artificial) with a constant and control it with the intensity slider. (To be truly realistic, the highest notes would have no volume envelope, but have a short sustain time intrinsic in the sample itself, and be programmed as a one-shot)

  • Wristlock
    Wristlock Member Posts: 3 Newcomer

    I did not know the highest octave does not have dampers! I wonder why that is though, having the option to kill the notes cant really hurt I would think but ok. That certainly explains the behavior of the vst.

    I still dont understand why I have to modulate the release time instead of being able to adjust it directly, but the modulation trick (constant or velocity) works so I guess Ill take it.

Back To Top