Traktor Kontrol S8 won't turn on - PSU is OK

mannyCal69
mannyCal69 Member Posts: 5 Member
edited September 2023 in Traktor Software & Hardware

Hello there folks, I'm having an Issue with a S8, it won't turn on, it's completely dead, no lights or any response.

Measured the PSU pin with a tester and it gives 15v correctly (I use it daily on a S5), when I plug it in and push the power button, nothing happens, also tried with USB connected too, but my PC won't detect it at all.

As far as I know, the controller worked ok and then was stored for 3 years without being used. I saw the power jack in detail and it is rusty.

Any ideas? Thanks in advance!

Tagged:

Comments

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,524 mod

    Sorry to hear it. That sucks.

    I'd take the unit to your local electrician shop to inspect it and see what happened.

  • Kubrak
    Kubrak Member Posts: 2,751 Expert

    If the connector is rusty, it may give bad contact....

    You could try to open S8 and measure, if mains goes inside.... Or let Pro have a look at it.... Generally it should not die if not used, but maybe that a condenser or so might get bad over the time....

  • mannyCal69
    mannyCal69 Member Posts: 5 Member

    Thanks for your replies! I'll try disasseming by my hand first, it's hard to trust people to have the necessary precaution with these delicate tools. Already made contact with 2 specialized dj tech service and made contact with NI to see if they have spare parts to sell me.

    Do you know by chance if there's anything like a service manual for there units?

  • zephry
    zephry Member Posts: 549 Pro

    My S8 finally went dead, it was slowly over 2years taking longer to turn on. Sometimes it would turn on if dropped from about an inch or so on the table. But now, not at all.

    Please post if you find the solution.

    Currently we replaced it with a used S5. The S8 has been reported several times in the older discontinued forum of doing this. So we avoided buying a used one, especially since used still go for 300 or more USD$.

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,480 Expert

    That's not good. I am sorry to hear that. I have no solution, just wanted to say this.

  • mannyCal69
    mannyCal69 Member Posts: 5 Member


    Hello, I think I saw your case in reddit, I don't discard this could happen to this S8 as well, I just tried to power it for some seconds, so I'll try with time. I also saw a 4 months old comment from a user saying he opened the S8, made ground with some component by touching it and the problem dissapeared forever (I sent him a message for more details but no response).

    Today im opening it and checking each component of the power pcb with a multimeter, if I find anything relevant I'll come back to you.

  • mannyCal69
    mannyCal69 Member Posts: 5 Member

    Thanks for your support! I know I'm going to win this battle 😆

    I'm eager to get it working and as a fullstack dev I also want to update the open source mods for the screens and other controllers so they can work with the latest version of traktor.

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,480 Expert
  • mannyCal69
    mannyCal69 Member Posts: 5 Member

    FIXED IT!

    Problem was just that corrosion - not oxide - on the negative plate inside the power jack. cleaned it using a little piece of sandpaper on a pair of tweezers and voilá! Good as new.

    Thanks everyone for your help!

Back To Top