Help

Why i can't register 2.6.8 on my mac ?

Answers

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,542 mod

    That could be one of beta versions that we had. Can't say for sure.

    But that version you should skip anyway because it suffered a ton of changes under the hood (and 3.7 as well)

  • lord-carlos
    lord-carlos Member Posts: 2,061 Expert

    Register? Or install?

    I think Traktor Pro 2 is no longer supported on latest mac. Might be wrong though. Better wait for someone else to confirm it.

Back To Top