Komplete Kontrol & Kontakt killing long notes

NorwegianStranger
NorwegianStranger Member Posts: 3 Newcomer

Hi! I'm having a problem on with both the Komplete Kontrol plugin and Kontakt. When I'm playing the Alicia's Keys piano, long notes are being cut out when I'm not letting go of the keys.

It's even stranger that it only happens on one of two computers.

Computer 1 (problem): Windows 10, 16GB ram, Intel i7, Presonus 1824c, Komplete kontrol A61, M Audio KeyRig 49.

Computer 2 (No problem): Windows 11, 16GB ram, intel i7, Presonus Audiobox iTwo, Komplete kontrol M32.

I have a sustain pedal connected to my A61, but I don't think that's the problem because it doesn't help to remove it, and it doesn't help to only allow the keyrig 49 as controller for the midi-track.

The problem does not occur when I choose a different piano plugin such as Arturia Piano v2.

The settings for the NI plugins are the same on both computers as far as I can see.

Comments

  • JesterMgee
    JesterMgee Member Posts: 2,121 Expert

    Is the Kontakt library on an SSD or HDD?

    Have you tried playing with the pre-load settings for Kontakt:

    Running from an SSD here with 32GB Ram, no noticeable dropouts. Keep in mind that the Alicia keys instrument is pretty big and if on a HDD loading into memory could take some minutes so after initially loading you may be able to play it but there may be many samples not fully loaded and so will cut off. As a test, after loading wait for a good 5 minutes then test again or disable that "background loading" option and you will likely not hear anything when played until everything has loaded.

    A HDD will make it take a while, SSD will likely allow loading within a minute

  • NorwegianStranger
    NorwegianStranger Member Posts: 3 Newcomer
    edited September 6

    I did not think of that. I have my library on an external ssd, and I use the same ssd for both computers using USB-3. So if that's the problem, it's really strange. But I will certainly give it a try at first chance.

    But will I be able to access these setting from the komplete kontrol plugin as well? Or do I have to do it in Kontakt and then komplete kontrol will read settings from kontakt?

  • NorwegianStranger
    NorwegianStranger Member Posts: 3 Newcomer
    edited September 9

    It solved the problem by raising the preload buffer size in Kontakt, which is great. But I would like to be able to use the instrument in Komplete Kontrol plugin as well, and it turns out the settings from Kontakt doesn't sync between the plugins. I can't find a setting for preload buffer size inside Komplete Kontrol.

  • JesterMgee
    JesterMgee Member Posts: 2,121 Expert

    You need to open the Edit view:

    Then that allows you to access the Kontakt settings and should be able to adjust the pre buffer and voice settings in there

Back To Top