SSD read time extremely slow suddenly - What to do?

2»

Comments

  • Kubrak
    Kubrak Member Posts: 846 Saw
    edited April 22

    Hard to say, what is the source of your problem.

    I have loading speed around 500 MB/s on my system. But I have NVMe SSD that is way faster than yours SSD. I am on Win10.

    But also on Win7 I get 20 MB/s Kontakt reading speed on SATA6 SSD. (I guess lower loading speed is not only because of 10x slower SSD, but also weak CPU contributes...)

    Try to monitor CPU performance (clock and temperature) during Kontakt library loading.

  • ThomasM74
    ThomasM74 Member Posts: 4 Sine

    In which file system are the SSDs formatted? It can make a huge difference.

  • m.bernbrich
    m.bernbrich GermanyMember Posts: 4 Sine

    I added that MUSIC SSD to my existing Win10 system as NTFS, whole disk as one partition.

    (All my drives are formatted with NTFS)

  • m.bernbrich
    m.bernbrich GermanyMember Posts: 4 Sine

    I did not expect to contiue writing here, but…

    Here comes Part III of my Story:

    With these bad transfer rates, I believed that the SSD would be soon unusable. I started to run backups to external USB drives. Luckily there were no issues with the data on my SSD. It only took ~3 days (!).

    I then ran the SanDisk Dashboard Tool, but it showed no issues at all – all test were successful and the remaining health status was 100%. Unbelievable that this tool did not detect anything.

    I then removed data from the drive and the used space went down from ~85% to ~60%. I hoped, that the controller would catch up with cleanup and reorganising. I also activated TRIM explicitely (which Windows doeas as a default). During the next 24 hours the behaviour of my MUSIC disk did not change at all. I read about the issue of SSDs being slow when they get full – but what does ‘full’ mean? 70%, 80%, 90%

    Skip this if you do not like to read the tech details J

    (There is a kind of wasting space that accumulates over time when data gets deleted and written over time. Data is written in Blocks of 256K, while the smallest size inside the block is 8K. Basically it is much faster to write to an empty blocks, as the writing can start immediately. Writing to a partially filled block requires to read out the partials into a cache and then writing the whole block. Therefor, the firmware will prefer to use empty blocks. The more gets written, the more partial blocks exist and the more space is ‘wasted’. A garbage collector does the job of consolidating partial blocks and provides more free blocks. But this process needs time…)

    Formatting the Disk:

    I then used the Dashboard Tool to wipe the disk. Afterwards I did a format with the default settings (NTFS 4kb). Now I started to copy back from USB to SSD and I gained up to ~100MB/s. This time the USB drive was at 100% but the SSD was at 29%. So this time the USB drive was the limiting factor. At this time of coarse, the file size does matter a lot – the rate went down to 20MB/s when many little files were copied.

    Heureka!

    Let’s load the Pearl Concert Grand!


    Pearl Grand: , ~19s, ~70MB/s, 1320MB

    Grandeur:        ~5s,  ~36MB/s, 180MB

    Session Horns: ~15s, 88MB/s, 1320MB

    Resume:

    -         I am still not convinced that my disk is 100% in order. That firmware and the garbage collection should be able to reorganise the data in the background when ther are idle times.

    -         Observe the transfer or load times regularly to early detect any degradation. Do not wait too long, otherwise your backup will take ages.

    -         Everyone experiencing a similar issue: Backup and format your disk. If this does not help and your disk is less that a few years in age, contact your dealer for replacement (SanDisk has 5 years of warranty).


    _________________________________________

    My PC:

    Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz (6 cores), 32GB RAM

    System drive: Samsung SSD 840 EVO 120G SCSI Disk Device

    Music drive: SanDisk SDSSDH3 1T00

    NVIDIA GeForce GTX 1050 Ti

    Windows Version 10.0.19044 Build 19044

    Kontakt old: 5.8.1 R43

    Kontakt current: 6.7.1

  • SmokeyJoe
    SmokeyJoe Member Posts: 7 Sine

    I discovered an alternative solution which seemed crazy at first but it worked.

    NI advised me to copy one library from my SSD to my C drive and load it from there. I copied Alicia Keys (which is large and slow to load) and it took about 20 minutes to copy it due to the slow read times on my SSD.

    When I then loaded it from the C drive, not surprisingly it loaded almost instantly. But this is when a very strange thing happened...

    I then copied the same library back to my SSD (this went much faster at around 2 minutes). I then for whatever reason tried to load it from my SSD again and suddenly.... IT LOADED INSTANTLY!?

    I guess the library must have had a corrupt installation.

    I did the same with another library and the result was exactly the same.

    What I then did is that I deleted all my large libraries from my SSD and downloaded them again. Now they all work as they should.

    If you have a similar problem, try this.

Back To Top