m32 and Kontakt Plugin

narot23
narot23 Member Posts: 17 Member
edited August 2023 in Komplete Kontrol

Hello,

I'm enjoying my m32 quite a bit. It's a great controller, wish I could afford a higher tier. Nevertheless, the one issue I'm facing is that when opening Kontakt, I'm unable to browse, change presets, control the plugin, etc. It acts as if it's still in MIDI mode, and defaults to controlling the volume knobs of my DAW. The keys do get to the device and it plays, just the knobs and other controls aren't hitting Kontakt.

Does everything need to be through Komplete Kontrol? Or am I missing something here? I'm running Bitwig 5. Settings image is attached, do note, for DAW Output I have to select ANYTHING other than the m32, otherwise, the keyboard simply stays stuck in MIDI mode. I'm submitting a ticket on that portion, or if anyone does know a solution, by all means please share. Thanks!


Best Answer

  • MyStudioOne
    MyStudioOne Member Posts: 249 Pro
    Answer ✓

    Yup. You guessed it. The keyboard only integrates with Komplete Kontrol. So if you want to use the Kontakt interface, use KK in edit mode which loads the Kontakt interface while still giving you the keyboard integration.

Answers

  • MyStudioOne
    MyStudioOne Member Posts: 249 Pro
    Answer ✓

    Yup. You guessed it. The keyboard only integrates with Komplete Kontrol. So if you want to use the Kontakt interface, use KK in edit mode which loads the Kontakt interface while still giving you the keyboard integration.

  • narot23
    narot23 Member Posts: 17 Member

    That answers that, but poses another question. I have a few Kontakt Libraries that do not display in Komplete Kontrol. These are paid, but did not go through Native Access. What am I supposed to do in regards to those?

  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert

    If the developer of those libraries has not made a NKS library for them, you can try and make one yourself by loading Kontakt manually from the plugin menu, selecting the instrument you want, learning/mapping the parameters you want to use and then saving that as a template for that instrument.

    Or, contact the developer of the instrument and ask them to make NKS compatible

  • MyStudioOne
    MyStudioOne Member Posts: 249 Pro

    In that case, you'll find them here...If they are aren't you need to go to preferences and add the folder where the said plugins reside. Next startup or manual scan will add them for you.


  • narot23
    narot23 Member Posts: 17 Member

    Odd... they do not display in the Library panel, nor the Instruments VST3 panel. There are at least 4 libraries I have which display in the Kontakt Library, they don't have images, but they aren't showing up despite their location being added in the Preferences. Hm.

Back To Top