Please be advised that due to scheduled infrastructure maintenance, we anticipate downtimes for the Native Instruments websites and Native Access on February 28, 2024 starting at 06:00 CET. For more details, click here.

[Reaper+Kontakt 7] All piano instruments have unnatural low volume with MIDI Files.

SUNight
SUNight Member Posts: 6 Newcomer

Hey guys, this is my first experience with Komplete 14 standard, plus Alicias Keys, please don't be mad on me. I use Windows 10, Reaper 6.8 and Kontakt 7, but all the Native-Instrument piano plugins have unnatural low volume when playing with midi file. Here is my conditions:

  1. My midi file is directly recorded with USB flash from my Yamaha p515, and imported into Reaper;
  2. I also play the other VST with the same midi file, such as Keyscape and Pianoteq 6, which are pretty loud, so I don't think it is the midi file cause the low volume;
  3. When I use mouse click on the kontakt virtual keyboard, all piano sound loud and natural, but when playing with midi, the volume turn all the way down;
  4. I even test other daw, such as Cakewalk, Cubase AI with the same midi, kontakt also yields low volume with these platform;
  5. I also check other Kontakt third party Instruments, such as Foundations Piano and Memoir Piano, they both have low unnatural low volume;

I can have my conclusion that the Kontakt did cause the low volume, though I can bring the volume up with sliders, but when I did it, the sound seems a little muddy. So how may I fix that low volume problem, I just want the natural piano volume as the other plugins. Please help.

Tagged:

Best Answer

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod

    @SUNight You should check the velocity of your keyboard. By default the keys on the virtual keyboard of Kontakt is set at 100.

  • SUNight
    SUNight Member Posts: 6 Newcomer

    Thanks. Maybe you are right, the further question is, how may I change the velocity of my keyboard, I mean the midi file, if I just want to use the midi file I have.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod
    Answer ✓

    @SUNight I'm not really versed in Reaper but I found this video, that might be what you're looking for:


  • SUNight
    SUNight Member Posts: 6 Newcomer

    Thank you for your patience, I believe the video will do the trick. But what else if I don't want to change the velocity through the Reaper, the reason behind it is because other plugin have quite the normal volume level, if I edit the MIDI velocity, sure it will affects the other plugins too. Is there any other options that I can do this just within the Kontakt plugin itself? I have searched for the answer myself, but the result is in vain, maybe you can help.

  • stephen24
    stephen24 Member Posts: 257 Advisor

    Simplest just to turn up the volume in the instrument header. If it sounds muddy, that's how it's designed to sound the way you have played it. (Always best to record stuff using the instrument you intend to play it back on.) In this kind of instrument, lower velocities will trigger less bright samples.

    Or you can boost the velocity with a simple multiscript, which will affect all the instruments in that instance of Kontakt.

    on midi_in
     if ($MIDI_COMMAND = $MIDI_COMMAND_NOTE_ON)
      set_event_par($EVENT_ID,$EVENT_PAR_MIDI_BYTE_2,$MIDI_BYTE_2+10)
     end if
    end on
    
    

    Adjust the increment "+10" at the end of the 3rd line to taste, especially if it takes the velocity (MIDI byte 2) over 127.

  • SUNight
    SUNight Member Posts: 6 Newcomer

    Well, I believe this is a little beyond me, I still looking for a simple solution, but still thanks for your reply.

  • stephen24
    stephen24 Member Posts: 257 Advisor

    Couldn't be much simpler.

    1. Different pianos will sound different with the same MIDI sequence.
    2. A script is provided which will boost the velocity Kontakt will play. Paste it into an empty multiscript slot (look for KSP at the top of the Kontakt window, click Edit) and then click on Apply. As written, it will add 10 to the Velocity value, but you can change this.
  • SUNight
    SUNight Member Posts: 6 Newcomer

    Sorry 's been busy these days. But I really don't think that I should change the velocity of my midi. I had checked my midi, velocities were between 50~75, which were quite normal as a piano performance. Beside, although I had raised up the velocities as 10 point higher, the volume still too low. Is there any other option that I can truly fix this? Thank you.


  • DunedinDragon
    DunedinDragon Member Posts: 272 Pro

    Does Alicia's Keys have any mixer capabilities built in? If so that's where you would best be able to adjust the outgoing volume and tone.

  • SUNight
    SUNight Member Posts: 6 Newcomer
    edited July 2023

    Of course they have, but it doesn't feel right if I have to mix them to bring the volume up, because if I did that, the sound wasn't as clean as I was expected. To make the volume sound right(I mean as loud as other Youtuber), I have to push the volume slider to +12, plus + 6bd in the mixer(see the picture below) for every Kontakt piano plugin I applied. But I looked into other guy's video, they didn't need to turn up anything, but still got a very clean and loud volume. I don't know what happened to my computer.

    And I suspect that if other people have used other sound plugin to make their piano sound loud and clean, if that so, please shed some light on me.


  • Murat Kayi
    Murat Kayi Member Posts: 428 Pro
    edited July 2023

    Right now, noone really knows what you are experiencing, so it's a bit fishing in the dark.


    But, IIRC, Noire has its own velocity mapping right? Even the older piano VSTs by NI have a velocity knob to change the dynamics. Maybe that will give you better volume. (In your screenshot, try the dynamics button, but there should also be a curve for mapping velocities). Noire has a lot of tweaking possibilities under the hood which should give you the sound you're after.

Back To Top