Traktor 3 Demo does not recognize M-Audio speakers

Paul LGLV
Paul LGLV Member Posts: 25 Newcomer

Hello,

after verifying that Traktor 2 does not work with Windows 11, I downloaded a demo version of Traktor Pro 3.

It's going pretty well and I'm considering buying the license (it's 50 €).

The problem is that I have M-AUDIO BX5 speakers and it doesn't recognize them, they are They are connected with a cable to the headphone jack (it can only be heard through the laptop's speakers).

Is it a demo version stuff, or is it not configurable?

PS: In Traktor 2 worked well.

Thank you,

Best Answers

  • lord-carlos
    lord-carlos Member Posts: 2,023 Expert
    edited July 2023 Answer ✓
    • Connect speakers and headphones to the S2
    • Select S2 (ASIO) in the audio setup
    • Make sure master is routed to main out in output routing
    • Turn master up a bit
  • Paul LGLV
    Paul LGLV Member Posts: 25 Newcomer
    Answer ✓

    Ok, It seems to work now.


    Thanks :)

Answers

  • Kubrak
    Kubrak Member Posts: 2,745 Expert

    It is configurable. I think that setup is the same/simmilar like in Traktor 2.

  • lord-carlos
    lord-carlos Member Posts: 2,023 Expert
    edited July 2023

    Can you share a screenshot of your Audio Setup and Audio Routing settings?

    If you own Traktor 2 pro, the upgrade should only be 25 EUR, but only until tomorrow. Good luck.

  • Markovicz
    Markovicz Customer Care Posts: 381 mod

    HI @Paul LGLV,

    let me try to understand the current situation:

    In Traktor 3, the built-in sound card of your PC is selected as audio device and you are receiving its output via the laptop speakers, correct? This would mean that everything is fine on the Traktor side.

    If the signal is now not being transmitted to the speakers even though a connection is made via the headphone jack, this cannot be caused by Traktor but must somehow be caused on the Windows side.

    Given the fact that between the successful use with TP2 and the current situation your OS has been updated to Windows 11, one must assume that this brought the change and that a setting in W11 is responsible.

  • Paul LGLV
    Paul LGLV Member Posts: 25 Newcomer

    Here you are some picks



    I can't get music to play on the external speakers :(

  • lord-carlos
    lord-carlos Member Posts: 2,023 Expert

    What sound device are the speakers connected to? The S2? If yes then you need to select the s2 in the audio setup, and make sure they are routed correctly under Audio Routing

    If they are connected to another device, for example the laptop itself, you might want to select Realtek WASAPI shared.

    But then you lose headphones that are connected to the S2.

  • Paul LGLV
    Paul LGLV Member Posts: 25 Newcomer

    That's the amazing thing, whether I connect them to the S2 or the laptop they don't work when selecting that option :(

  • lord-carlos
    lord-carlos Member Posts: 2,023 Expert
    edited July 2023 Answer ✓
    • Connect speakers and headphones to the S2
    • Select S2 (ASIO) in the audio setup
    • Make sure master is routed to main out in output routing
    • Turn master up a bit
  • Paul LGLV
    Paul LGLV Member Posts: 25 Newcomer
    Answer ✓

    Ok, It seems to work now.


    Thanks :)

  • Markovicz
    Markovicz Customer Care Posts: 381 mod

    That's good to hear!

Back To Top