4-D-Encoder in Ableton no longer gives me control

Ceymi
Ceymi Member Posts: 3 Newcomer

Hello, I am since a few days proud owner of a S49 and Komplete 14 Ultimate. But I have the following problem.


Here's the scenario:

I am using Ableton Live 11 with a Komplete S49

- I start a new project

- On Channel 1 i load the plugin Komplete Kontrol

- Channel 1 is on record

- Channel 2 is the A Reverb Channel at the very bottom

- The browsing window appears on the S49 and I can select a sound, set ARP and Scale.

- After I move the 4-D encoder to the right, the second channel is selected/marked and I still have Channel 1 on Record.

- The real problem: After doing this, I have no more control over Sound/ARP/Scale on the S49. The Midi Control window pops up and none of the above buttons are accessible anymore. BUT I can still play the unselected sound in channel 1. I can switch back to the first channel, but no matter what I do, I can no longer adjust the scale/set ARP or change/edit the sound.

It happens even if I have a second channel with Komplete Kontrol

Before: (Yes the problem also occurs when I have selected a sound)

After pushing the 4-D-Encoder to the right and back to left :

^thats exactly the same like before switching und going back


Many thanks for your help

Best Answers

  • JesterMgee
    JesterMgee Member Posts: 2,575 Expert
    Answer ✓

    If you open a KK instance on a track, top right is an icon for your keyboard, You can click that to gain focus back. This shouold not be needed but is a way to manually get control back.

    When you use the encoder to move between tracks the ARM button on the track should light up which is what sets focus, this only (should) occurs when using the keyboard to move between tracks, if you manually click this does not happen.

    Just make sure in Live preferences Record tab you have the option for Exclusive Arm set

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,595 mod
    Answer ✓

    @Ceymi Do you still experience this issue? If you do, please get in touch with our specialists here: http://bit.ly/NIsupport_KKontrol

Answers

  • Ceymi
    Ceymi Member Posts: 3 Newcomer

    I just noticed it also happens when I mouse click to select another channel and switch back.

  • JesterMgee
    JesterMgee Member Posts: 2,575 Expert
    Answer ✓

    If you open a KK instance on a track, top right is an icon for your keyboard, You can click that to gain focus back. This shouold not be needed but is a way to manually get control back.

    When you use the encoder to move between tracks the ARM button on the track should light up which is what sets focus, this only (should) occurs when using the keyboard to move between tracks, if you manually click this does not happen.

    Just make sure in Live preferences Record tab you have the option for Exclusive Arm set

  • Ceymi
    Ceymi Member Posts: 3 Newcomer
    edited June 2023

    @JesterMgee

    Thank you for your reply. The Exclusive ARM setting is set.

    I just tested it again. if i record in channel 1 and have loaded Komplete Kontrol, then change to channel 2 with the 4-d encoder, ARM switches to channel 2. if i then press left with the 4-d encoder, i select channel 1, but ARM does not switch on Channel 1. When I mouse click on pc to turn on ARM, I can play the instrument in channel 1, but I can't make any settings with the s49 and I can't press the Browse, Plug-In, Scale or Arp buttons.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,595 mod
    Answer ✓

    @Ceymi Do you still experience this issue? If you do, please get in touch with our specialists here: http://bit.ly/NIsupport_KKontrol

Back To Top