S3 - RCA unbalanced out not working

Options
DJ Uncle G
DJ Uncle G Member Posts: 2 Newcomer

Hi I have an S3 with the RCA unbalanced output not working on either channel, It was working only one channel previously. Both 6.5 Booth outs and both XLR balanced outs work just fine.

Is there an easy fix for this problem? I have opened the unit up, and checked continuity from the cable terminals on the output board to the RCAs and they are good. So the problem could be further back.

I am not an electronics person. But if someone knows where to look next I'd appreciate the advice.

Thanks

G

Answers

  • Sunborn
    Sunborn NKS User Library Mod Posts: 2,465 mod
    Options

    There is no "easy fix" on such things. If it's "burned" it has to be replaced, or most likely, either forget about it and live like that, either buy something new.

    However in some cases (mostly for old hardware), an anti static spray might help. Anti static sprays are effective in many different situations, from preventing dust accumulation on electronics to protecting sensitive components from electrical damage due to electrostatic discharge.

    Otherwise, try a deeper approach (start with the link below), or forget about it.


  • DJ Uncle G
    DJ Uncle G Member Posts: 2 Newcomer
    Options

    Thank you Sunborn,

    I have already used a digital meter to trace continuity back to the main board.

    Seems like your suggetion "live with it" will be the way to go. I have already made a pair of XLR to RCA leads to plug into my domestic amp.


    Cheers

    Gordon

  • Sunborn
    Sunborn NKS User Library Mod Posts: 2,465 mod
    Options

    Yep, unfortunately the "live with it" option is the unpleasant reality for many similar cases..

    But you know, at the end the "problem" turned to something good! XLR connections are far superior, and now because of this "problem" you will have to use them! 😊

    Also, can you please mark this question as "solved" (answered)? Thanks!

Back To Top