Komplete Audio input interfaces, producing pops and clicks...

HawaiianEye Member Posts: 13 Member
edited January 2022 in Other Software & Hardware

This is a specific discussion for those who have or have had this annoying problem. I would like for those who have, to check what they have done, and take a survey of what circumstances this problem rears its ugly head,in their specific case.

I noticed pops that sound like a bad LP record, randomly happening, when listening to output on my Komplete Audi 1, no matter what is being played, be it input signal, output from any source, including all DAWs, mp3s, YouTube, etc. Whether the output source is Speakers or headphones. This problem has been reported pertaining all Komplete Audio series. But not everyone experiences this. As a matter of fact, only a small number compared to all Komplete Audio owners. This reported clicking and popping seems to have no effect on actual recording results, except if you listen back from the so called "offending" Komplete Audio device. This seems to be an unsolved problem in other forums also, when you do a search. Please refrain from skipping ahead and giving your suggestions. I am not asking for suggestions. Only answers from others who have experienced this problem.

I've done extensive troubleshooting, and listening/ reading the advice others send out to those who have this problem. Most who apply the different avenues of advice still have the problem. This is what I've trouble shooted / shot so far:

1.) Try a different cable. I have many cables, and I've tried them all. No change in problem. 2.) Try a powered USB hub. Conversely: DO not use a USB Hub. Both = No difference. Also try different USB sockets. And if you have USB C, try that. Nopes! 3.) Try changing specific settings/prefs, either in computer or NI products, or both. This was by far the most varied, and complicated section of suggestions offered. Including manually overwriting basic programing instructions. Nope, same no good results most everyone with this problem has. My personal trouble shooting findings: 4.) Possible RF interference. Lighting fixtures, appliances, electrical switches, or electronic sources too close. Nope, didn't solve. 5.) As mentioned above, the pops weren't recorded. The random intervals of the popping, were not identical in listening to the recording through the Komplete Audio interface.. While recording from any source, say for instance, Komplete Kontrol keyboard, I hear occasional clicks and pops. Listening back with headphones, there are no clicks and pops in the same places during recording. If I play the music back from the computer's speakers, or using headphones direct to PC without using Komplete Audio 1, No clicks. Perfect! 6.) Final findings. When I hooked my Komplete Audio1 to my Desktop PC, instead of my new laptop. It worked flawlessly! With Any cable, with or without USB hub, No special preferences/ settings, No RF disturbances. Just plug and pray!

Rereading the complaints, I found many of them were from NEWER PC Laptop users. I have a brand new, ultra capable laptop, I use for photo, video and audio production only. The popping happens only with this new laptop. I believe this problem is with modern Laptops. Some complaints come from users who had no problems if they went back to their older laptop. I believe this is NOT a brand problem. But a modern component that new laptop makers use that injects noise into the USB interface.

To those who experience this problem; Only you can add to these assumptions of mine. If you are struggling with this bad problem, what are your findings, compared with mine? It is not a Native Instrument problem. But, beyond that, Laptop companies try to play the blame game. Maybe we can add up our findings.

If you had this problem, and found the solution, please let us know. But please, if you have never had this problem, there have already been seeming endless solutions offered by "experts", in other forums, that don't work. I am not looking to rehash suggestions.

Mainly, if you have this problem, what kind of computer are you using? What brand? Do you have another computer you can try it out on? Do you find the same outcome as I do? Any input on this from you, may help shed some light on the subject. I certainly appreciate your input!


Best Answer

  • HawaiianEye
    HawaiianEye Member Posts: 13 Member
    Answer ✓

    Thank You ALL! I resolved my problem. As soon as I unplugged the ethernet connection and went to straight WiFi, the clicking totally disappeared. I have very hi speed provider and latest router. My laptop is a newer Legion 5, and it's 8' away from router. I also have the ethernet cable standing by, if needed.


  • thomast0001
    thomast0001 Member Posts: 5 Member
    Reading through your description (and attempted fixes), I immediately thought of one specific problem I've experienced: line noise. This is closely related to the classic ground loop. The solution? An audio isolator. (Reading through your attempted solutions, I don't see that listed.) Unfortunately there are a lot of junk isolators. The one I bought is the Cable Matters Ground Loop Noise Isolator. (Be careful to buy the item from a reputable dealer. You might consider buying it directly from the Cable Matters website if it's in stock.)

    For my specific scenario, I use Powerline Ethernet adapters for networking. Unfortunately that has the side effect of introducing noise on all power connections (including ground). I was experiencing extremely annoying pops and crackles on various audio outputs, including line level and headphones. I was even detecting the crackles and pops at times over headphones when the equipment was turned off! I tried a variety of solutions but finally hit on an audio isolator. The blessed dead silence was immediate and heavenly!

    So that's what I'd try. The symptoms you describe sound exactly like what I was experiencing, although the cause may be different. The bottom line is electronics have many interconnections going from source to destination, and there are a lot of places ground loops and line noise can be introduced. The fact that the problem "moves around" depending on what's hooked up to what, or what version of equipment is being used, with cables making no difference, points strongly in that direction.

    I sincerely hope this helps! However, as I said, reading through reviews of various isolators it's hit or miss getting a decent one. Pick one carefully.

  • McFeud
    McFeud Member Posts: 3 Member

    Just guessing here, but I think your laptop has too fast USB ports.

    In windows it should be up to USB device driver software to limit bandwidth so that it does not get overboard

    And you might also turn off USB battery savings from settings

  • JesterMgee
    JesterMgee Member Posts: 2,462 Expert

    Hesitant to make a "suggestion" as you are only interested in the limited scope of users who experience this exact issue and seem to feel no one else but you has the experienced skills...

    But i'll live on the edge,

    Have you checked your Power Profile settings for your laptop and made sure you have set the MIN CPU to 100%, disabled all sleep functions for USB/HDD?

    As you have said, many new laptop owners complain of similar issues and laptops usually have CPU throttle settings which dynamically change the CPU power which often is the cause of random hiccups.

    But this is only a suggestion as I didn't read you tried this, tho could have easily missed it in your essay.

  • Kubrak
    Kubrak Member Posts: 2,743 Expert


    from where do you hear crackles? From audio plug of notebook or from audioplug of Komplete Audio?

    If the sound recorded is OK, the sound from Komplete Audio audioplug should be also OK. And what driver do you use for KA? Should be ASIO (not WASAPI) for best performance.

  • HawaiianEye
    HawaiianEye Member Posts: 13 Member

    Thanks for trying

    I will look into this, USB is the suspect in this, so Thanks!🙂

  • HawaiianEye
    HawaiianEye Member Posts: 13 Member

    Well, it seems you've listened before speaking! And that's good! I will look into your suggestion asap.

    Some have asked me questions that are answered in my post. I imagine, they see how lengthy my essay is, and want to have me write back to answer personally to them, without reading.

    You on the other hand, offered me something practical! Thanks!😉 I will let you know if it solves this problem!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @HawaiianEye Sorry to see your post only now, did you find a solution to this problem ? We have an article that might help you here: KOMPLETE AUDIO 1 / 2 / 6 MK2 Audio Issues (Windows)

  • HawaiianEye
    HawaiianEye Member Posts: 13 Member
    Answer ✓

    Thank You ALL! I resolved my problem. As soon as I unplugged the ethernet connection and went to straight WiFi, the clicking totally disappeared. I have very hi speed provider and latest router. My laptop is a newer Legion 5, and it's 8' away from router. I also have the ethernet cable standing by, if needed.

  • JC Selva
    JC Selva Member Posts: 2 Newcomer

    Hello, it's been a long time since the last comment, but I liked a lot this post and I felt the need to add my impressions.

    I stopped using VST to play live for a long time, almost 10 years, since I had the privilege to play on a Motif.

    A few months ago I came back to the VST game again with NI hardware (Komplete Kontrol M32 + Komplete Audio 2) on an i3 11th gen. Windows Home Laptop. I usually play live on Ableton Live 11.

    I'm really disappointed with those random clicks and pops. I tried the NI Audio Issues help (for Windows), bought expensive USB cables and headphones, optimized Windows configs the most. I think I tried everything.

    I know... An i3 is not the recommended processor. But you know what? I tried a 3rd gen. Scarlett Solo and the pops magically disappeared. I could use 16 samples buffer + 96kHz rate easily for most Hybrid Keys, Noire, Omnisphere plugins with no pops at all.

    On the other hand, with NI Komplete Audio 2, I only stopped hearing pops with 1024 samples buffer + 48 kHz rate.

    That's my specific case, I won't generalize. I found some good suggestions here worth trying, but I'm really considering selling my NI Audio Interface. And I say that unfortunately because I really enjoy NI software and controllers.

  • devhour3D
    devhour3D Member Posts: 1 Newcomer

    Just found this searching while trying to solve the clicking issue while I was trying to sample a loop I made to another device. Everyone might have tried it already, but I thought I’d share anyway in case not.

    While reading and reviewing, I had success. Hopefully this works for anyone having this issue.

    in Komplete Kontrol, I went to edit>preferences and under device, I selected my UA Volt interface. The clicking went away instantly. it was previously set to my sound card.

  • HawaiianEye
    HawaiianEye Member Posts: 13 Member


    I'm still getting suggestions, well after I found and posted my specific solution, nearly 2 years ago.

    Please read "Best Answers"

    The pops totally disappeared after I unplugged my hardwired router/ modem combo, and connected to wifi.

    My Laptop was where the problem came from. Since this worked, I had no reason to reconnect to ethernet cable. Problem GONE!

  • JC Selva
    JC Selva Member Posts: 2 Newcomer

    Unfortunately this doesn't work for me. I don't even connect my equipment to internet to avoid any possible interference.

Back To Top