Do I need to upgrade my macbook after 3.8?

Bonjah
Bonjah Member Posts: 15 Member

Hi, the latest beta 3.9 doesnt support os catalina. And thats the latest OS I can use on my macbook air mid 2013. I know I can still bypassing it. But thats not longterm how I want to use my traktor. So is 3.8 the latest update I could use?🥺 and will I miss out on the rest of the updates I sign up for when I paid for pro plus?

Best Answer

  • Markovicz
    Markovicz Customer Care Posts: 381 mod
    Answer ✓

    Hi @Bonjah,

    I'm afraid your assumption is correct: without the possibility to run a more modern macOS on your 10-year-old computer, you will not be able to use Traktor higher than 3.8 on that machine.

    If upgrading your Mac is not an option, please let me know - I'll connect you with my colleagues in Customer Support in order to handle the subscription issue.

Answers

  • Uwe303
    Uwe303 Moderator Posts: 2,911 mod

    Hello,

    if it's the last officially supported version, it can work with the older os but don't has to, there's of course no guarantee. And mostly on mac sooner or later a newer update will no longer work with your os version for sure i would say. That's what experience with mac tells us so far.

  • Markovicz
    Markovicz Customer Care Posts: 381 mod
    Answer ✓

    Hi @Bonjah,

    I'm afraid your assumption is correct: without the possibility to run a more modern macOS on your 10-year-old computer, you will not be able to use Traktor higher than 3.8 on that machine.

    If upgrading your Mac is not an option, please let me know - I'll connect you with my colleagues in Customer Support in order to handle the subscription issue.

Back To Top