Komplete Kontrol x Ableton: Re-Enable Automation always on when reloading a project

holonology
holonology Member Posts: 60 Member

Hi folks. A quick question on Komplete Kontrol behaviour in Ableton.

I'd like to try out how KK might sit in my workflow for loading NKS sounds as I have Komplete, Diva and some Arturia vsts.

I decided to use a Play Series instrument from Kontakt to test this (Ethereal Earth.) The first time I ran this test, when re-loading the project, the parameters I had saved re-set to zero. After doing some googling, I decided to toggle a couple switches on and off - namely Unwind automation ID's and changing Ableton's Audio Input Device. I have since turned these switches back to their default settings, and I haven't noticed Ableton's behaviour changing.

What has changed is that Re-Enable Automation is always on when reloading a project with KK loaded. The good news it the automation is saved. But I'd be interested to hear if anyone else has had this issue, and if this is the expected behaviour (aka: on every project load, you'll need to click the re-enable button?)

If there are any other settings I can try or workarounds for this, I'd be interested to hear if others have had this and what else there is to try to make using KK as smooth as possible.

Best Answer

  • JesterMgee
    JesterMgee Member Posts: 2,475 Expert
    Answer ✓

    Yeah I can confirm this and don't have any real answer for why this occurs so if you are in the Beta group, post it as a bug and I will add my 0.02c

    I did a quick test loading both KK VST2 and VST3 and same thing occurs in both so this isn't a VST2/3 issue.

    Loading KK on a track and recording some automation for a control I note this is disabled on project load with the Enable Host Automation button lit. As you mention, the recorded automation is there and works, but you need to click the EHA button for it to work.

    Loading an instrument on a track without KK in the look is fine, automation is already enabled and ready to go. I have a feeling this has actually always been the case, I just auto-pilot to enable automation if I need it so have never thought more about it.

    One reason could be because KK is integrated with hardware and the control surface slot device it may disable the automation on load for some practical reason. Not sure if anyone from NI can weigh in on this one or if it is a bug but it's a simple one to work around.

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 4,039 Expert

    Which parameters are you talking about? Do you mean changes in the Instruments are not saved with the Ableton project?

  • holonology
    holonology Member Posts: 60 Member
    edited May 2023

    Hey @LostInFoundation - so here's how it plays out. I load KK and get this:

    Then, when I play with parameters in whichever KK device I load; they show up and are active here:

    Typically when I use VST's they reload in the last "active" state that the plugin was in when I close the session. So I would expect to load the session, hit play and then see those parameters light up red for the active automation. But in the case of KK, it reloads with the automation de-activated & greyed out.

    And in this first test, for some reason, when I hit play the 2 parameters in this project completely reset to zero (not sure why). Quick note: I toggled Unwind automation ID's off then on again as I mentioned above, and I have not been able to replicate this last problem on the tests I've done since - so hopefully that was just first time unlucky.

    So my real question is, why would KK do this when the typical behaviour is for a device to reload in the state it was saved? Is this normal for KK? Does anyone else experience this, and is there a known fix for this to avoid having to re-enable automation on every session load?

  • JesterMgee
    JesterMgee Member Posts: 2,475 Expert
    Answer ✓

    Yeah I can confirm this and don't have any real answer for why this occurs so if you are in the Beta group, post it as a bug and I will add my 0.02c

    I did a quick test loading both KK VST2 and VST3 and same thing occurs in both so this isn't a VST2/3 issue.

    Loading KK on a track and recording some automation for a control I note this is disabled on project load with the Enable Host Automation button lit. As you mention, the recorded automation is there and works, but you need to click the EHA button for it to work.

    Loading an instrument on a track without KK in the look is fine, automation is already enabled and ready to go. I have a feeling this has actually always been the case, I just auto-pilot to enable automation if I need it so have never thought more about it.

    One reason could be because KK is integrated with hardware and the control surface slot device it may disable the automation on load for some practical reason. Not sure if anyone from NI can weigh in on this one or if it is a bug but it's a simple one to work around.

  • holonology
    holonology Member Posts: 60 Member

    Thanks for commenting @JesterMgee - even if (as you say) it's normal behaviour for KK, then this would be good to know.

  • SpiceCadet
    SpiceCadet Member Posts: 1 Newcomer

    I realize this is happening in all of my sessions with KK loaded. It's resulted in a bounce without automation which I had to re-send for mastering. I'd appreciate an update and confirmation of this as a bug that NI is aware of.

Back To Top