Why is my Maschine Plus library reset every now and then?

Options
badaz
badaz Member Posts: 36 Member

Hello,

ever since 1.4.5 update, my library is reset every now and then. After a number of restarts (say 2 or 3), projects, sound, groups, etc. all appear empty, except for the "maschine" category, all expansions disappear, I have to rescan everything which takes quite a long time since I own many expansions. Is there a bug with this release? Is it a known bug? Is anyone experiencing the same thing? Thanks.

Tagged:
«13

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 4,311 Expert
    Options

    It definitely sounds like a bug. And a bad one, if you lose all your projects (or by rescanning you gain access to them again?)

    I would suggest to turn off Wi-Fi and see if this avoid the problem. Not a solution, if this is a bug…but at least you can avoid to lose anything important till it is fixed.

    Did you contact NI support?

  • badaz
    badaz Member Posts: 36 Member
    Options

    I don't loose anything, it seems like it's juste the inner DB that indexes everything that is present on the SD card which is reset and has to be reconstructed. I did not contact NI but I guess I will. One other thing, I'm using the Maschine plus with an external power bank, maybe it comes from this

  • LostInFoundation
    LostInFoundation Member Posts: 4,311 Expert
    Options

    If it is the case, it’s a bad sign. A power bank giving ANY kind of trouble is something I would not put my Maschine+ life in its hands

  • badaz
    badaz Member Posts: 36 Member
    Options

    I have yet to confirm this hypothesis by trying to reproduce the bug using the provided power outlet

  • Rototo85
    Rototo85 Member Posts: 17 Member
    Options

    Hi i get the same thing than you do you find a solution ?

  • just_jump
    just_jump Member Posts: 77 Helper
    edited April 2023
    Options

    If the sd card is getting corrupt and requiring reindexing as a result you might try another sd card. And certainly backup projects elsewhere.

  • Rototo85
    Rototo85 Member Posts: 17 Member
    edited April 2023
    Options

    I m not sur is the sd card because i Can see all my sample ... When i start the maschine i Can see as white flash on the pads is it the same for you ?

  • badaz
    badaz Member Posts: 36 Member
    Options

    I didn't notice anything weird like pads flashing white. Last thing I tried : repair the sdcard on a mac, it did not find any errors, yet after I did it the library was reset again, it had to rescan everything one more time. Has not done it again since, but I've only restarted it three times, and left it connected to the power outlet to verify my hypothesis. I'll post here again if I have any news. Do you guys also noticed that while using a DC external power bank ?

  • Rototo85
    Rototo85 Member Posts: 17 Member
    Options

    I m not using external power bank

  • D-One
    D-One Moderator Posts: 2,952 mod
    edited April 2023
    Options

    If your power bank meets the power specs required and you are not using unrecommended solutions like 'RipCord' then there's zero chance it's your power bank's fault, it's just electricity, it doesn't matter where it comes from unless the source is broken.

    I never had any issues with mine but also don't use it often.

    Cheap SD cards can have all sorts of issues, I wouldn't use the original one ever, not in a million years. Decent Sandisk Extreme Pros @ 90mb/s are very affordable nowadays for realistic moderate sizes.

  • badaz
    badaz Member Posts: 36 Member
    edited April 2023
    Options

    I just realized that I had never wintnessed it yet, but today I restart the Maschine +, booting takes longer than usual and I got the pads light fixed white for some seconds. After that it finishes booting and my library is blank again. Rescan has no effect, so I restart the Maschine + and boom ! It is now slowly reindexing everything again (loading spinner + expansions slowly appearing one after the other in the browser view).

    By the way, I can now confirm that the bug is not cause by the use of an external DC power bank since the library was reset even though I have not been using the power bank since the last library reset, it has been plugged to the power outlet since my first message here.

    About the microSD card I use: I specifically bought it for the Maschine +, so it is not the stock one, it is a Samsung Evo Select microSDXC UHS-I U3 A2 V30. It is supposed to be faster but I did not really notice any difference when copying my files to it, so maybe it is still not fast enough? Do I need a V60? a V90?

    @Jeremy_NI you've helped us before in a previous thread about another bug, do you have any insight to share or, if it is a bug, do you know if the devs know about it?

    Simply put, the bug is :

    • Maschine plus sometimes takes longer to start, ending the boot sequence with fixed white pads, then everything that is on the microSD card is not visible anymore. Next restart makes Maschine + start reindexing everything again.

    System Version 1.4.5.2

    Maschine Version 2.16.1 (R0)

    Firmware 0.1.9

  • LostInFoundation
    LostInFoundation Member Posts: 4,311 Expert
    edited April 2023
    Options

    In facts it sounds exactly like a problem in reading the SD card now.

    If you find an answer about your EVO select being a good one or not, let me know. I have an EVO plus unopened from some years (I read they are practically the same product) ready to be used. What is the read/write speed of yours?

  • just_jump
    just_jump Member Posts: 77 Helper
    Options

    Sometimes it’s the card speeds sometimes it’s compatibility of cards with controllers and other issues. GoPro used to be notorious for not working with a lot of cards so they put out a list of known working cards. Granted some of those were actually speed issues too.

    I wouldn’t expect high speed cards would necessarily be the issue in and of itself but some underlying compatibility perhaps. I haven’t done a search, but I imagine there are at least user recommendations for M+ cards floating around.

    Generally the Sandisk Extreme series (I think extreme) are among recommendations when all else fails.

  • Rototo85
    Rototo85 Member Posts: 17 Member
    edited April 2023
    Options

    I ve got a sandisk.extreme with the same problème but when i restart nothing is reindexing

  • LostInFoundation
    LostInFoundation Member Posts: 4,311 Expert
    Options

    just_jump is correct.

    I would also add a simplistic “expensive cards are better than cheap ones” 😂😂😂

    Not always the case, but sometimes you pay for the quality/speed/reliability

Back To Top