Welcome to the new and improved Native Instruments online community. Join our active forum of 40,000+ members for discussions and much more.

Kontrol S2 MK3 stopped working after updating Windows

Hey everyone,

I updated windows yesterday to the latest version (10.0.22621 Build 22621) and suddenly my S2 MK3 has stopped working.

I have read through the trouble shooting guides online - I have the current update for Traktor Pro 3 (3.8). I have the driver installed and current firmware for the S2 MK3. (i have also tried re-installing these, reverting to past versions of Traktor and past versions of Windows, but it still doesn't work. I've tried different USB adaptors as well. And I have tried using the controller manager to restore the S2 MK3 to the default setting.

The device lights up when i plug it in, but then the lights turn off.

I can still control volume from it if I have a track playing that I have manually loaded to the decks via my keyboard. But otherwise the controller is unresponsive.

Any ideas of what the issue could be?




  • Ognu
    Ognu Member Posts: 1 Noise
    edited March 19


    Got exactly the same issue as you right now. Can someone else help us ?

    These are the updates that I got recently :


  • SteveKDJ
    SteveKDJ Member Posts: 80 Sine

    I heard from others that Win. 11 226xxx.xxx versions have many problems..

    I just recently installed the 22000.1696 version with a little tweaking (removing the bloatware, and a couple of registry settings) and other than the basic bugs it works fine for me, I also updated all the drivers I could.

  • SteveKDJ
    SteveKDJ Member Posts: 80 Sine

    I take it back, today not long ago the sound faded away, buzzed humming a little. the Tractor started life on its own. the spare meters, sound ran up and down. Either the ghosts or someone, but there was no one here :)

    I put the ASIO driver on, now it was good, the sound went off once, froze, then as if nothing happened. 

    it breaks all the time on Win 10 too.

    really nothing to say, sorry...

  • ChunkyLurker
    ChunkyLurker Member Posts: 2 Noise


    I did some further trouble shooting and decided to install traktor on a different computer, and when i plugged in the Kontrol S2 MK3 it worked straight away. So the problem was obviously with the computer I was using, not the Kontrol S2 MK3. So it's a good reminder to always try a different computer when troubleshooting!

    I still haven't worked out what the issue is that's causing it yet though. think it's time for a hard restart of my computer.

Back To Top