Kontakt 7 multi output audio routing not recognizing into Ableton Live

BabaGhanoush Member Posts: 4 Member


I used to be able to route audio with no problems from GGD Drums out of Kontakt and into Ableton. However, for some odd reason this has stopped working. I may have installed something and now Ableton doesn’t even receive the audio in from Kontakt. I’ve tried every routing scenario I can think of and nothing works. Please refer to my video to see the issue: https://youtu.be/irBYqn64y7M

any help will be appreciated please, thanks!


  • Gee_Flat
    Gee_Flat Member Posts: 906 Guru

    I know nothing, but I'll throw this out there. I watched your video but can't remember. Did you try loading into an empty project? Any existing projects with other instances of Kontakt could cause confusion as the manual says.

    Did you try it again with K6?

  • BabaGhanoush
    BabaGhanoush Member Posts: 4 Member

    I tried it with kontakt 6 previously as well, then I uninstalled it thinking it was interfering with the other installed Kontakt versions I had. I uninstalled all of it, then only installed kontakt 7 fresh. It still wasn’t working even before all of that.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,591 mod

    @BabaGhanoush I'm not sure what's wrong here but when I follow this article here: How to Route KONTAKT to Multiple Outputs in Ableton Live It works for me. You have to set up the outputs before loading any library, then open Kontakt again, load your drum library and assign the different parts to the available outputs. Not sure if it's the problem here but if I strictly follow the steps, it's working.

    Also when having issues with Kontakt's outputs, it can be good to reset everything:

    Reset KONTAKT's Output Section

    Please close all audio applications before following these steps.

    1. Click on the Windows start button on the bottom left of your screen.
    2. Type "%localappdata%" and click on the option which appears.
    3. Navigate to the Native Instruments.
    4. Depending on the KONTAKT version you are using, delete the following folder:
    5. KONTAKT 5: "Kontakt 5"
    6. KONTAKT 6: "Kontakt"
    7. KONTAKT 7: "Kontakt 7"
    8. Rename the "default" folder to "default_OLD":
    1. Start the KONTAKT application in Standalone Mode (not as a plug-in in your DAW). This will reestablish the default output settings.
    2. If KONTAKT is now running correctly in standalone mode, close the application and try opening the plug-in version of KONTAKT from your DAW.

  • BabaGhanoush
    BabaGhanoush Member Posts: 4 Member

    Hey Jeremy,

    thanks for attempting to help. Unfortunately that didn't work. I tried both methods. When it comes to resetting the Kontakt Outputs, all I had was Kontakt 7, so I didn't delete it. I renamed the "default" folder to "default_OLD". When I Opened the standalone version, I did see that it updated some of the files and even created a new "default" folder, no dice. Any new help will be much appreciated at this point. Thank you in advance!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,591 mod

    @BabaGhanoush Sorry, this one slipped. Do you still need help on this one? If you do I'll create a ticket and forward it to one of our specialists.

  • BabaGhanoush
    BabaGhanoush Member Posts: 4 Member

    Hey @Jeremy_NI , yes unfortunately I do still need help on this. I can't figure it out.

    Thank you in advance.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,591 mod

    @BabaGhanoush I contacted you by email regarding the issue, we'll need more info on your system.

  • Once.Nate
    Once.Nate Member Posts: 1 Newcomer

    I seem to be dealing with the same issue. It is just no longer working as intended and I am dead in my tracks. Pun intended.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,591 mod

    @Once.Nate If nothing in this thread has been helpful you can get in touch with our Kontakt specialists here: http://bit.ly/NIsupport_kontakt

Back To Top