help me decide which mac update it's the better for me on traktor 3

Hello everyone I am from Greece i have been djing tha last 10 yeras with traktor s1mk1 with lion and never update from 2,5,3 if i remember, but never crashed all these years of course analysed the songs, always hot cue and ssd hard disk.

Now the time has come to update I have ordered s4 mk3 and I wanted to play with 3,2,0 traktor and mac mojave (some friends djs have it and it is very stable).

Could you please recommend the next reliable macbook edition with te right traaktor edition that are stable.

Now I cannot put mojave and add traktor 3,6,2 that's why i am trying to figure what to do.

Best Answer

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,547 mod
    edited February 2023 Answer ✓

    Hey there, greetings to Greece. Mojave will work great with S4 MK3 and 3.4 has been the most stable version.

    2014 and 2015 MPB will do the trick. Don't buy 2016 to 2019 models as those suffer from keyboard issues. If you can, get an M1 mac. Those don't overheat like Intel versions and are silent in their operation. Hope this helps you decide.

    Edit: 500th post right here :)

Answers

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,547 mod
    edited February 2023 Answer ✓

    Hey there, greetings to Greece. Mojave will work great with S4 MK3 and 3.4 has been the most stable version.

    2014 and 2015 MPB will do the trick. Don't buy 2016 to 2019 models as those suffer from keyboard issues. If you can, get an M1 mac. Those don't overheat like Intel versions and are silent in their operation. Hope this helps you decide.

    Edit: 500th post right here :)

  • stavropoulos
    stavropoulos Member Posts: 2 Newcomer

    Thank you for your time you are very specific adn that helps a lot, thanks again.

Back To Top