Unable to perform Kontrol S4 MK2 Jog Wheel Calibration

nickw Member Posts: 2 Newcomer

I have a feeling my Kontrol S4 Mk2 requires it's jog wheels calibrated, since the left jog wheel no longer registers press/touches on top (which would normally stop a playing track). The right one seems to be intermittent, but only occasionally registering touch.

I've attempted to re-calibrate in Traktor by going to Preferences -> S4Mk2 -> Recalibrate Left/Right. It then asks "Press and hold its corresponding 'Load' button for 2 seconds".

For both jog wheels I cannot get past this step. Nothing seems to happen no matter how long I hold the "load" button for either side of the controller.

I have also tried to reset Traktor by moving Traktor Settings.tsi to the desktop to no avail. Device Updater 1.7.0 says my device is up to date (version 69). I've tried different USB cables and even a whole different computer.

I have also tried to calibrate with Controller Editor, by going to Preferences -> Kontrol S4 MK2 has no option for jog wheel calibration like is explained in the calibration guide: https://support.native-instruments.com/hc/en-us/article_attachments/205618865/Jog_Wheel_Calibration_Guide_English.pdf (I would assume the guide is written with Mk1 in mind?)

I had a strange thought - perhaps the new version of the software is no longer able to calibrate older controllers due to some software regression? I had the thought to run the older version of Traktor 2 on my Mac from a date closer to the release of the S4Mk2, however I am unable to install these older versions without an error "No previous installation found".


  • Dwainfnx
    Dwainfnx Member Posts: 1 Newcomer

    Good day. Did you get any answers. I’ve had the same issue. After not running my setup for 6 months due to studio rebuild both my jog wheels no longer scratch but only perform pitch bend duties instead. I’ve tries switching on and of the disable jog wheel push option but nothing changes. If you’ve managed to get things sorted I’d love to know how to resolve this. I can’t upgrade my Mac OS anyway further as it’s quite old but felt no reason to do so as it’s worked very well for years and still going strong so I’m worried about upgrading traktor also as I was perfectly happy with the older version and the remix decks alongside my 2 technics turntable. I don’t really scratch with the jog wheels but they are very handy for stopping and queuing up tracks for beat gridding and still.

    all good then and maybe I’ll start a ticket with NI if. Get no answers.

  • nickw
    nickw Member Posts: 2 Newcomer
    edited February 16

    Unfortunately no solutions yet.

    Sounds like there might be a commonality between both of our situations - In my case the controller had been stored for quite some time before being used again. Perhaps throwing the jog wheels out of calibration?

    I've been in contact with NI support, but they have mostly taken me through the steps I outlined above without any resolution. I was hoping they'd be able to help me perform a calibration at the very least, but now they've put me in contact with the hardware repairs/returns team.

  • Mark_NI
    Mark_NI Customer Care Posts: 376 mod

    Hi @Dwainfnx ,

    given the troubleshooting steps you have already taken, it makes total sense to contact Tech Support here.

Back To Top