Maschine MK3 VERRRRRYYY buggy on M1

LPR Presents
LPR Presents Member Posts: 5 Member

I dont know if this is an apple silicon specific issue, but Maschine MK3 is very buggy on Ventura 13.1, To be sure, I have a fully loaded 16" MacBook Pro Max. I do video production on this beast and it performs flawlessly on all 3 production suites I use (adobe, Davinci, FCPX).

For the most part, Maschine works ok. But the sound often stops entirely even though the clips are playing, there is no output to the headphones or line outs.

It often hangs at the maschine launch screen on the hardware itself.

the controls dont start this way (when maschine works), but they eventually become very sluggish, and I have found that I am using mouse and keyboard more than the hardware itself because of this.

Even more frustrating is that Komplete Select loads in all the sounds and instruments that I dont have into the browser, and frustratingly I queue through the library only to find that much of the library is unavailable because I dont own the plugin. WHY WOULD YOU DO THIS IF NOT ONLY TO TRY AND SHILL A SALE. It's predatory and ridiculous.

I will be returning the Maschine tomorrow when I have time. What a waste NI, you used to be legendary with product and support within it.

I suppose my question is, is anyone else having this issue or is it just me?

Answers

  • D-One
    D-One Moderator Posts: 2,689 mod
    edited February 2023

    I suppose my question is, is anyone else having this issue or is it just me?

    Not really, works fine in my M1.

    You however have the M1 Pro Max, I have no experience with that model and did notice it seemed to be more problematic some NI stuff for some odd reason but there are currently no support notes about it on the compatibility articles, so it should work.

    Are you on the latest MAS version and firmware? Tried both with Rosetta-2 on and off?

    Does MAS have microphone perms in Security & Privacy?

  • LPR Presents
    LPR Presents Member Posts: 5 Member

    Ya, ive done all the troubleshooting. So very frustrating. The worst is the audio cutting off, if that happened during a gig....

    Wait, I take it back, the worst thing is the cluttered library that is full of plugins and sounds that I dont own but were installed alongside Select. Very frustrating.

  • D-One
    D-One Moderator Posts: 2,689 mod
    edited February 2023

    TBH I never heard of audio cutting-off issues, if it was due to Apple Silicon there would be a ton of threads reporting the same I think; something else is going on.

    Wait, I take it back, the worst thing is the cluttered library that is full of plugins and sounds that I dont own but were installed alongside Select. Very frustrating.

    That's not supposed to happen neither. Give a couple of examples of plugins that show u that yu don't own.

  • LPR Presents
    LPR Presents Member Posts: 5 Member

    Battery, Monark, im assuming, and thats only because I read the forums. the fix was to navigate to my expansions library and delete all the battery kits, which I did, but now the plugins just show up as a power plug in my browser. The message I keep getting (for atleast a third of the library) is Not compatible with apple silicon or has not been updated to vst2 or vst3 or something like that. But then when seeking through the forums ive read that that is no longer an issue for the plugins im using with Select. And going through the update history it shows that the Maschin his updated and that the VST3 issue has been fixed.

    The audio cutting, the maschine hanging at launch forcing me to restart my MacBook, the cluttered library full of sound is can't use, the support tickets ive submitted but gotten no response... its all very frustrating and tbh I want to return it. But... license transfer is not available in the first 60 days, and although ive submitted a ticket I do not know what this means for the return, or if they will even take it.

    Ive been using NI for years now, although I took a 2 year break from music to concentrate on a few video projects I had going. I was soooooooo excited to get back into the NI world, I remember outstanding support through the phone, or very complete NI forums, but most of the links listed in the forums bring me to a page no longer available page, or simply nothing. This whole experience has been horrible. Select issues, the HW issues, how frustrating the support loop is.... So far you have been the only light in this whole experience, and that is simply because you have replied, thank you!!!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @LPR Presents Sorry you have had a bad experience. Maybe there are a few things to look into before sending it back? There were performance issues in previos versions of the Maschine software with M1 Pro and Max but with the latest updates and especially the last one that brought Sillicon native compatibility these don't seem to happen anymore.

    If you have a little bit of patience left, maybe you can check a couple of things.

    Does Maschine have Full Disk Access? How to Enable Full Disk Access on macOS

    Did you install NI content on an external hard drive? What is the format of that drive? On recent Mac OS it should be APFS, as explained in this article: Notes on Hard Drive Formats on Mac Computers

    Some part of the content in Komplete Select uses Kontakt inside Maschine, make sure to give Full Disk Access to it as well.

    Some also use Reaktor. Reaktor is not yet M1 native compatible, so when using Reaktor instruments, Maschine would need to run in Rosetta mode.

  • LPR Presents
    LPR Presents Member Posts: 5 Member

    Ya, Ive done ALL the troubleshooting. Given full access, tried rosetta and not, and my m1 has 1tb of storage that is mostly unused, I install ALL programs and apps to the internal SSD, and edit video off an external M.2

    none of it seems to work, and not being able to use maschine effectively since I purchased it has steadily deflated my desire to use it. Ive spent most of the morning this morning troubleshooting it but lo and behold, mid production of what I thought was a killer beat audio cut off. not to mention while trying to load drum kits or even one shots from the select library getting the constant message that they are not compatible.

    If they are indeed compatible like you suggest, how would I go about reinstalling them? Seeing the little power plug icon is also frustrating and acts as a reminder that I only have half of what I thought I paid for.

Back To Top