Pressing Filter Knob doesnt jump back to the middle (default)

Hello All


Im having the problem when i press the filter knob it just wont jump back to the middle (to off).


In the past this been worked fine, i googled the problem bit did not find a person having the similar problem as me.


I have traktor pro 3 installed and have the traktor kontrol s2 mk2 device.

i hope someone knows the solution as i really cant resolve the problem.


Regards


Danny

Best Answers

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,461 Expert
    Answer ✓

    That's something you can do youself, by overmapping the controls. Rather than explain it i will map it for you.

    • Open Preferences - Controller Manager
    • Select the S2Mk2 mapping (Device Dropdown) and delete it.
    • Right below it is the button Add... Press it and load the mapping i have uploaded.
    • In the menu on the left side, select Traktor S2Mk1/Mk2. Set the Gain Knobs to Filter (Shift:Gain).

    That should do it.

    If you need it the other way around (Gain (Shift:Filter)), change the modifier condition for both knobs to M1=1 (instead of 0).


  • Sûlherokhh
    Sûlherokhh Member Posts: 1,461 Expert
    Answer ✓

    Make sure that you only have a single mapping for the controller in the controller manager drop down menu. Delete the old ones.

Answers

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,461 Expert
    Answer ✓

    That's something you can do youself, by overmapping the controls. Rather than explain it i will map it for you.

    • Open Preferences - Controller Manager
    • Select the S2Mk2 mapping (Device Dropdown) and delete it.
    • Right below it is the button Add... Press it and load the mapping i have uploaded.
    • In the menu on the left side, select Traktor S2Mk1/Mk2. Set the Gain Knobs to Filter (Shift:Gain).

    That should do it.

    If you need it the other way around (Gain (Shift:Filter)), change the modifier condition for both knobs to M1=1 (instead of 0).


  • zephry
    zephry Member Posts: 545 Pro

    I don't have the S2mk2.

    I am confused, you can press the filter knob on that controller?

  • zephry
    zephry Member Posts: 545 Pro

    Wouldn't the reset cause the parameter to jump the next time the knob is turned?

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,461 Expert
    edited February 2023

    The S2Mk2 has an encoder knob as gain+filter control at the top of the channel that can be toggled as well as turned. Pressing it (with the mapping i provided) will reset the filter from whatever value it had (from 0 to 1) to 0.5. This has no influence on the turning behaviour.

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,461 Expert

    😋

    Of course it's probably a lot more comfortable to just map one of the FX knobs and button for each channel. You would lose a bit of FX control but the Mk3 doesn't even have those.

  • Danny1985
    Danny1985 Member Posts: 4 Member

    thanks so much guys works all fine now with these settings! greetings


    Danny

  • Danny1985
    Danny1985 Member Posts: 4 Member

    Ok Sulherokhh


    Now i have the problem that the browsing knob jumps 4 lines instead of just 1. That means if i wanna put the next track below im unable to do that with the controller, which is very nessesary for me, i avoid mouse when im mixing.


    Thanks in advance


    Danny

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,461 Expert
    Answer ✓

    Make sure that you only have a single mapping for the controller in the controller manager drop down menu. Delete the old ones.

  • ditto_bass
    ditto_bass Member Posts: 1 Member

    I have this same issue and this did not work for me after I followed the instructions

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,461 Expert

    In what way exactly did it not work?

  • Stevan
    Stevan Member Posts: 1,511 Expert

    From the reports I've seen in Traktor forums the problem is the push button on the Gain encoders.

    It seems that resetting the filter or Gain doesn't work in latest versions of Traktor.

    I advise to add a mapping command to reset these controls.

    Add In --> Mixer --> Gain Adjust (or MIxer FX Adjust) / type-button / mode-direct / value=0.5


Back To Top